Add or Update Content - RACHEL-Plus 2017 Software Release

In 2017, we released new software to enable updating or adding new modules to your RACHEL-Plus device via a web browser (no linux required). See more at the tutorial video here: Updating or Adding Content

Great video! All new RACHEL-Pluses will be like this going forward. Older devices can be updated to the new software, it just takes a small bit of work.

The process requires an internet connection and some basic familiarity with the command line. Here are the steps:

  1. Hook up the RACHEL-Plus to the internet – video instructions here (watch 0:33 - 1:12 to plug RACHEL into internet)

  2. Determine the IP address and ssh to the device – video instructions here (watch minutes 1:33 - 3:19 to get into RACHEL via SSH) – but use the updated password from the default passwords page.

  3. Run the following command, making sure to get everything on one line: sudo rsync -Pavz --exclude modules --exclude /admin/admin.sqlite --exclude '.*' --del rsync:// /media/RACHEL/rachel/

  4. Run the following command: sudo killall lighttpd

After all that you will be up to date with the latest RACHEL software. Going forward, you’ll be able to install future updates through your browser, as described in the video above.

Post any questions or clarifications below!

1 Like

I was able to use these instructions to successfully update my Sept 2016 software to the new 2017 version.Thanks Jonathan!

Here are my tips/things I learned:

  • I used a PC so had to download an SSH client and chose PuTTY which is free and worked fine.

  • I’m in the U.S. so my internet connection was not a problem and using PuTTY is legal.

  • Logging into the Administrative Dashboard sometimes doesn’t work. Using an incognito window in the browser has remedied this for me.

  • At first the SSH client couldn’t locate my device. After trying many different things, I found the problem was in my settings on the RACHEL Plus Administrative Dashboard. Under GENERAL SETTINGS, there is a choice for “network mode of this device”. Make sure “Full Internet Access” is your setting.


Thanks for the additional pointers - I’m sure others will find them helpful!

This is a great update to the RACHEL Plus software. The instructions are very clear.

One question, after uploading the new software with rsync, is it required to restart the RACHEL Plus? (I did and it worked fine).

On another note, I located the IP address of the RACHEL Plus by viewing the connected devices on my router. My RACHEL Plus was listed as WRTD-303N-Server. I’ve read that this string (or something close to it) is the default SSID for the system. That may help you locate the device and its IP address.

Another way to try is to view the connected devices on your router before and after connecting the RACHEL Plus. The new device should be the RACHEL Plus. (Pretty obvious, I know :wink:

1 Like

Perhaps someone else has encountered my issue after running “rsync” and restarting the device: there are no modules listed under the RACHEL banner on the home page, and after successfully logging into the “Admin” link, the admin/modules.php page is entirely blank.

My box is dated around Christmas 2015 … is the rsync geared to such an “old” box?

Thanks! . . . . . . . . Ken

I’m not sure it is, but I think the only change is that your modules have index.htmlf segments in them and the new boxes have rachel-index.php (though the content of those two files is the same). I wonder if you can rename a few modules index.htmlf files and see if that wakes them up.

Yes, my modules all have htmlf files:

cap@WRTD-303N-Server:/media/RACHEL/rachel$ find . -name \*htmlf\*

Editing a couple of them hasn’t helped … let me try renaming them all.

I could copy all except GCF/ hesperian/ edison/ practical_action/ and ka-lite/

Looking in kalite/, for example, I cannot see why I do not have the permissions to create rachel-index.php.

I note that while the index.htmlf file is owned and grouped by “root”, my new rachel-index.php files are owned and grouped by “cap”.

I rebooted and I still see no modules in either the home page or after logging in to administration. I have nothing to click on.

This may have to wait for @jfield to troubleshoot. Do you have an admin page now?

Can you download a full new module and see what happens?

I can log in to admin, but as mentioned above, after successfully logging in I see nothing … a blank page … no opportunity to click on anything or read anything. It is entirely white.

The address bar reads: (which matches the IP address of the RACHEL box on my router)

Got it, sorry, I misunderstood.

It might be best to put all the modules on a USB external hard drive (cp modules external) and then just start clean with a USB reformat of the device. Is that an option?

Not for the RACHEL-Plus in Tanzania, which is why I’m practicing on the RACHEL-Plus in Canada.

Where in tanzania is it? We have lots of users there who should have a 500gb external drive we could provision locally.

Still want to get a better answer from jfield but he’s is South Africa at the moment.

Hi - back online. So I’m not sure what’s going on here as I don’t have a device that old to test against. In fact the new admin should work with either rachel-index.php or index.htmlf files (it looks for both). Also, that command shouldn’t delete anything in the modules directory So it’s something else going on here.

My guess is that on the older devices there’s something missing from the PHP installation. If you can show me some of the output from /var/log/httpd/error_log on that device it might help in identifying the problem.

The brute-force solution would be to re-install the system software using the recovery USB, but let’s see if we can figure out what’s missing first because it might be a relatively easy fix…

Ok - finally got a chance to dig into this – and it was an educational experience. Turns out there was no sqlite on the device, which is the database system we use for everything now. I didn’t realize we ever had Pluses without sqlite, but I guess we did!

In the future with devices this old, I would definitely recommend starting with the CAP1 Recovery USB as I had to make lots of tweaks! But I believe I have it all working now, with an updated ka-lite as well – so check it out and let me know!

My Rachel Plus is a 2015 model and I can’t update it or even find where to upload my own content. I get a 404 error when trying various addresses as instructed by information I find in the manual.
Where can I find information on a CAP 1 Recovery USB, or alternatively, can I trade this old one in for a discount on a new Rachel-Plus?
A fresh Install wouldn’t hurt anything since it has been in storage and unused for the last couple of years. If that would be an option for me, could you point me to directions on how to do this?


Rose, I found this page Create and Use and USB Recovery that claims to work for the 2015 models, but I’ve posted there the problem I am having haven done all of the process and I am awaiting feedback. I hope this helps … perhaps there won’t be problems if you follow the process.

Good luck! . . . . . Ken

1 Like

As @jfield mentioned, we have come a LONG way since we starting building RACHEL. You have the same situation as Ken (@gkholman) posted here. The bottom line is that you have a RACHEL-Plus with a different partition schema then we now use. All that is detailed in the link above. I would recommend updating to our new partition schema. After reading that post, if you have more questions, please don’t hesitate to ask.

1 Like

Thank you Jeremy for the information. I will now go around the schools updating the contents now. I found the video very useful. Thanks once again. Laso Mana, Papua New Guinea