Bad Gateway trying to open the local content hub


I had a teacher trying to upload some videos to the Local Content hub and it worked the first time she uploaded some stuff. She said she’s not sure what happened, but now when we try to open the link “View and Upload Content” which takes us to the page, it just throws a “Bad Gateway” error:

502 Bad Gateway
nginx/1.10.3 (Ubuntu)

Can anyone offer some advice on what to try? I’ve taken the Rachel-Corrections device back to a different building that has internet access and run all the updates. I’ve also tried removing the Local Content module and reinstalling it. Neither has helped. All the other modules seem to be ok from what I can see.


Hi @john.ipson - I think you’ve taken all the standard steps we would recommend. You can send the device back to us for us to refresh it and take a look, but you’ll lose any uploaded content in the process. Doesn’t sound like a big issue given you can’t get to uploaded content, but this would also include any user accounts created in things like KA-Lite.

Would you like to proceed down that path?


Yes that would be wonderful. Thanks :slight_smile: How do you want to proceed?

Hi @john.ipson – can you send us the device directly?

We’re at:

World Possible
4482 Barranca Parkway
Suite 118
Irvine, CA 92604


do i need to put an rma code? I will ship it off today. thank you :slight_smile:

We can usually identify the order and device based on the MAC ID. If you have a copy of your order, it’d be helpful to throw it in there also, but we’ll figure it out if not.