Booting Pi3+ not happening?

Hi All, I have the latest (as of 18/04/2018) Pi image from worldpossible and this boot fine on the Pi3 but I can’t get it to boot on the Pi3+
I would be grateful for any thoughts on this issue

We’re aware of the issue but have not begun working on it.

Does anyone have any suggestion as to what might cause this?

my guess is a

sudo apt-get update

command in the terminal should update the rachel-pi OS to be compatible with the new 3+, but I can’t say for certain.


sudo apt-get upgrade

I do tihnk you could search online for making raspberry pi 3 image compatible with 3+ and see what happens.

Thanks for the hints. I’ve tried both and also followed the upgrade from jessie to stretch I found here
Neither solved the issue.
I read in the stretch notes the change from mysql to mariadb might cause some issues but my knowledge for this is sadly lacking.
I’m hoping someone clever can come up with a solution :slight_smile:

I should say upgrading the os from jessie to stretch did not stop it from booting on the Pi3