Boundless module search not working

I have downloaded and installed the Boundless zim file. It works fine, except the search function. I have other zim files installed and the search all works fine on them. I also did a search using ‘kiwix-search’ on the zim file and it worked, so it has an index. Looking at the code, it appears that the Boundless zim is using a Php search facility that doesn’t work, while the other modules use a native search capability.

Does anyone have any suggestions on how to fix the search capability?

HI @Mark_Knittel,

Both the en-boundless-static and en-boundless modules we have were scraped from the boundless website and then had a custom search functionality built for them. They don’t use Kiwix or ZIM files as far as I know. If you’re having issues with en-boundless search it might be worth trying the en-boundless-static module instead.

If you are using a new downloaded ZIM file from another source it’s likely a new RACHEL module has to be built from it. If you have a link to the ZIM you are using I’d be happy to do that.


Thanks. I used the zim file from Kiwix. However, I tried the online version of Boundless on the WP website. Search did not seem to be working there as well. Is there a reason?
Also, a couple of other questions:

  1. What’s the difference between the static and regular file?
  2. The Kiwix zim is much larger (12gb). Why is the Rachel one so much smaller?

Hi @Mark_Knittel,

The search might not work on the live preview server due to how the files are hosted there vs being hosted on a RACHEL device. The search on does work for me.

The RACHEL modules we host are not all Kiwix based and our version of boundless was scraped a few years ago. It is not a ZIM file and are likely from a different source so they will not match in size.

Kiwix are developing different methods to scrape websites and while those ZIM files are available to download, they do not seem to be supported yet, even in Kiwix Desktop. The Boundless ZIM for instance is at

and if you click it the page won’t load at the following link where it mentions service workers

I have not found a way to load these files yet. If you can provide a link to a ZIM file that loads in Kiwix Desktop I would be happy to look at making a RACHEL module from it but it’s possible they still can’t be hosted live on a webserver platform.


Hi James. I’m just following up with our exchange a few weeks ago about the Boundless module, Kiwix, etc.

  • I did try the Rachel Boundless module loaded, but search is not working on that. I’m not using Rachel natively, but a version of it running on Ubuntu 18.04. Is there a dependency in Rachel that I can check on to make sure that search works? (BTW: I also use Nginx, instead of Apache, but I don’t think that matters.)
  • I use Kiwix-server to host about 10 zim modules, and they work great. (They also work on Kiwix desktop.)That includes Boundless. The search function works on all of them, except Boundless. I downloaded all of them from here: Welcome to Kiwix Server

Any other suggestions?

Which version of kiwix-serve are you running?

The best place to check for PHP errors is within the Nginx logs at /var/log/nginx/error.log. It’s hard to say what is going on without knowing the exact device configuration.