Changing settings in Admin

I want to change the module content and reorder it in Rachel Pi-3’s admin section. The tutorial on the web for Rachel Pi says that the admin password is “Rachel+1”. I tried this repeatedly in several different ways. What password should I use to gain access to the Rachel Pi-3 admin section.

@creafsny Will you try these:

rachel / rachel
root / rachel
admin / Rachel+1

The root / rachel combination worked. I am working with an educational NGO that is engaged with three elementary/middle schools in the French-speaking Democratic Republic of the Congo. As an initial step, we are exploring RACHEL as a way to get project-based-learning modules and teacher training materials into the hands of our teacher counterparts. The French language content in Rachel is valuable, but not as complete or relevant for us as is the English content. Some of the teachers in DRC have some English language ability, so I am thinking of combining the French content with some English content into a single “bi-lingual” RACHEL pi library. Is there any reason why this shouldn’t be possible?

No @creafsny, that works – for the increased storage, battery operation, and ease of operation with this type of task we do offer RACHEL-Plus, which comes with both full sets of content ~380GB of content. For long-term projects, we strongly recommend this hardware which has a SSD for operating system files and a real 2.5" HDD for content storage built-in.

I have my admin password and can log into the Rachel admin, but when I try and login into the Advanced Hardware Control using the same user id and password I get an error.

Any suggestions?

Hi @efpatterson - Can you please confirm the version of RACHEL that you’re using? The default password for the advanced hardware control should be the same by default as the admin login. Also, are you using all lower case characters for “admin”?

A RACHEL-Plus and I can log in as admin with admin and Rachel+1 to the first level of admin. The issue is when I try and access the advanced options I use the same admin and Rachel+1 and I receive a message that the login and/or password are wrong.

Thanks for your help.

I’m going to message you some instructions to reset the password.

Thanks, I tired Putty and connecting and entered admin and Rachel+1 but received that password was not valid. Is there a root password? Also I have downloaded the latest recovery image and imaged to a USB drive.

Can I just power off, insert the USB I imaged and reload the system? And will that reset the passwords to the defaults?



Hi @efpatterson - I just messaged you the correct credentials.

The recovery USB image has to first be written to a 16GB or larger USB stick using a program like win32diskimager. Once it is written, turn the RACHEL-Plus off, put the drive into one of the USB ports, then hold the power button for 5 seconds to turn it on. Make sure you don’t power off the device during this process and wait until the blue power light goes out. That is when the recovery is complete. Next, remove the USB stick and power it on and it should be back to stock settings for that version.

Please be sure that the image you’re using is the current version that matches your device model. Also note that the recovery images available right now do not erase content and other settings on the main hard drive.


Thanks for your help, reloading the image worked.


1 Like

You’re welcome Ernie. Great to hear.


After installing modules, then trying to use Putty with admin and Rachel+1 the original error message comes up.

2021-07-15 15:52:26 Looking up host “” for SSH connection
2021-07-15 15:52:26 Connecting to port 22
2021-07-15 15:52:26 We claim version: SSH-2.0-PuTTY_Release_0.75
2021-07-15 15:52:26 Connected to
2021-07-15 15:52:26 Remote version: SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.4
2021-07-15 15:52:26 Using SSH protocol version 2
2021-07-15 15:52:26 No GSSAPI security context available
2021-07-15 15:52:26 Doing ECDH key exchange with curve Curve25519 and hash SHA-256 (unaccelerated)
2021-07-15 15:52:26 Server also has ecdsa-sha2-nistp256/rsa-sha2-512/rsa-sha2-256/ssh-rsa host keys, but we don’t know any of them
2021-07-15 15:52:26 Host key fingerprint is:
2021-07-15 15:52:26 ssh-ed25519 255 SHA256:pVnNGkwlVkxFQltsoFW6IRlUpbH/VYudeNOoCx/y4gM
2021-07-15 15:52:26 Initialised AES-256 SDCTR (AES-NI accelerated) outbound encryption
2021-07-15 15:52:26 Initialised HMAC-SHA-256 (unaccelerated) outbound MAC algorithm
2021-07-15 15:52:26 Initialised AES-256 SDCTR (AES-NI accelerated) inbound encryption
2021-07-15 15:52:26 Initialised HMAC-SHA-256 (unaccelerated) inbound MAC algorithm
2021-07-15 15:52:32 Sent password
2021-07-15 15:52:34 Password authentication failed

I am going to try reloading from the USB stick again to see if that allows me to connect. I am using the same computer and keyboard.


Hi @efpatterson - The putty login/pass is the root/**** one I provided in the private message. Not the admin/Rachel+1 default password. Are you having issues logging in over SSH or to the advanced hardware settings page?

I apologize, I forgot to save the private message with the login.

No problem at all. I’ll send it to you again.