Checksum for rachelpi_64EN_4.0.img

You’re welcome Mike. Any time you have questions or want to learn how something works feel free to ask. I’ll be glad to help. I hope everything is working for you with the full image. Good luck with the deployment!

Hi James.
Looking at the content of Rachel from the image I flashed, I have modules missing or no content loading as follows:
KA Lite Essentials Missing all together
Wikipedia for Schools Links are there but, no content when loading the pages .htm on the address bar
Wikivoyage Missing all together
Wiktionary Missing all together
Music Theory Navigating to pages but no content on .htm page
Any Ideas?
I’m downloading the .zip of the KA essentials bu no idea how to install the modules on the RPI.
There is the option on Rachel to Upload and view files do I have to use this method or how should upload the unzipped content in a different way. I’m totally ignorant with Linux commands. I have no problem with web servers but I’m not sure with Rachel though. On the borrowed SD the contents are there apart from the music theory.

Is this on the 64GB image? I haven’t used it in a long time so I can’t remember what modules are on it, but not all modules will be there as it’s meant to only fit the most popular content within the 64GB available. I do remember having some issues with bad links inside of Wikipedia for schools. The file upload module has a limit of 512MB so that isn’t the best way to install content and won’t support transferring modules as big as ka-lite-ess. That would require modifying a settings file and then unzipping using the pi. You will probably need to do some steps in Linux to add content. i don’t think it has the admin interface installation method, so you will need to unzip the content on your PC, transfer the folder to a USB flash drive, mount the drive in linux on the raspberry pi with some commands, transfer the module to /var/www/modules and then set it’s ownership for it to work. I will write out the steps if you want to do it this way.

Tanks James. I’ve already unzipped it and ready to copy. Do I have to do it through the admin option of Rachel and there is a user and password needed. As I said practically ignorant to Linux commands, although I am familiar with the directory structure and permissions because of my work with web servers.

I just had another thought. I did make an image of the SD that I borrowed. I’ll try and flash it to one of the my SDs and see if it will work but the help with the module installation will be a good experience for me and also improve my knowledge of Linux.

If the image you’re using has a desktop interface we can do this another way. If you only get a terminal ( black screen with text ) you can do it this way.

Boot up your pi with the USB flash drive attached to it. Log in with the username “pi” and the password “rachel”. Then do the following commands once you’re logged in by typing them out and then hitting enter.

  1. “sudo mkdir /media/usb”
  2. “sudo chown pi:pi /media/usb”

That created a directory called usb inside of the /media folder. Now you need to find your USB flash drive.

  1. “blkid”
  2. Look for your USB flash drive in the list of devices. Next to it you should see something like “/dev/sda1”. This is the name we need.
  3. “sudo mount /dev/sda1 /media/usb -o uid=pi,gid=pi” where /dev/sda1 is the one that was next to your drive in the list.

If that worked properly the drive is now mounted so you can access it. Now you need to transfer the folder with these commands.

  1. “sudo cp -R /media/usb/en-kalite-ess /var/www/modules”
  2. “sudo chown www-data:www-data /var/www/modules/en-kalite-ess”

This will take a while to finish. If that worked the folder will now be in the right place and set up properly. If the module you’re transferring is ka-lite you’ll need to do this extra step to get it running.

  1. “sudo sh /var/www/modules/en-kalite-ess/”

That should be it. For any other modules just change the folder name. One thing to look out for is that the downloaded zip files sometimes have two folders in them and the content is doubled so make sure only one folder is there. Once you get the hang of it it’s a lot easier. You can always flash the image again if something goes wrong but there shouldn’t be anything that breaks it in any of these commands.

Hi James. I have big problems. I have successfully flashed my two SDs and they will work for a while and after I log out and turn them of they fail. I did connect them to my TV via HDMI and I had a quick look at the code and where it ends it shows:
"[ 5.005127] —[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)"
I’m wondering what I might be doing wrong. Should I leave them on for a while before I shut them down through admin? They are both Sandisk Ultra and after they/ve been formatted thy both 67GB.
Howard send me some info on how to modules. My only thought is that might have not give enough time to Rachel to expand. I’m flashing both now and hope for the best.
If they boot I’ll let them on for a while before I shut them down through admin and that should show me If that early shut down would have been the problem.

Hello @jamesk
How can we replicate this using WinSCP and PuTTy combination? I’d like to perform the Copy using WinSCP

Hey Mike. Which image is this with? Is it with the 64GB image from the rachel servers or with one of the images I made?

Hi James is the one that I downloaded from the Rachel servers rachelpi_64EN_4.0.img.
I have it in two different laptops and the checksum is identical. One was downloaded on the 29th of October and the other on the 6th of November. I flashed them both last night one worked and waited about 10 minutes before I I accessed RPI and after I logged off through admin. when the signal was lost I turned it off. After a couple minutes I started it the green flashed once and then once again and after that nothing.
We are going to Zambia today and leaving home at 3:30 pm. I’m wondering if I must get a couple more Sandisk 64 GB ultra and try again. Any other advice. I still have Howards working one but I need to have two for both the Raspberry Pi 3B.
Thanks again for your help.

Hi James. After buying two more Sandisk SDs but the Extreme version, I flashed them both and everything works A OK. Just getting ready for the airport and I hope no more problems.
Thanks again for all your help once again and we’ll communicate when back from Zambia after the 21st.

Hi Mike. I’m glad everything worked out just in time. The main thing I would be careful of is making sure the shutdown is initiated from the shutdown button in the admin interface and then to wait 30 seconds or so after shutdown before disconnecting the power. That will help avoid the SD card corrupting. When you get back I can help you get my RACHEL image working if you’re interested. There should be some updates by then to help with things like showing the IP address. Have a good trip.


Hi @airsay. If you want to transfer the files over SSH from a different computer you can follow a tutorial like this one. That transfers them over the network. If you want to copy from a USB drive connected to the pi but still use putty the commands should be the same.

With WinSCP it’s drag-and-drop from local computer to remote. However it fails to complete due to access rights. What are the credentials for root?

It depends on the image you’re using. It could be root/rachel or root/raspberry.

Right. Thanks. I will try this out and revert