Checksum for rachelpi_64EN_4.0.img

Hi Does anyone know the checksum for rachelpi_64EN_4.0.img?
The only checksum mentioned is for the MD5.txt is for the 3.8 version.
I have already downloaded the image twice and used the recommended Win32 Disk Imager on two different 64gb sd cards but both won’t work.
Can anyone help?

I’m not sure about the checksum but I can try to help. What error does WIn32 Disk Imager give you? You might also want to try using Etcher from this link.

There is also an issue sometimes with 64GB cards not actually being 64GB but a little bit less, making the image too large to flash. Another thing you might be interested in is the new rachel-pi image I’m working on at this thread. It’s a work in progress but the image is small to download and you can install the modules you want from the interface instead of downloading a full 64gb.

Hi Jamesk.
Thank you very much for replying. I don’t get an error. It does what is suppressed to do. Everything looks ok when I check the contents, however, when starting the Raspberry Pi 3b the red light comes one it only blinks twice on the green and that’s it. I borrowed one from giakonda to make sure that the Pi works and it’s ok.
I was wondering if got corrupted during download and it takes ages 24hours minimum. I did it twice on SDs but no difference. I’m now copying the giakonda’s working SD to another SD Using a portioning coying software and hope for the best. I just wanted to know the checksum to make sure. The other thought I had it could be the SD’s. If the copy doesn’t work I’ll try new different 64 GB SDs.
I did download Etcher earlier this morning but I didn’t use it yet. I’ll setup another laptop and try Etcher and hopefully, if it works I’ll let you know. As it happens I did have a look at your thread and sound s interesting, my problem is that I’m good with Linux and being a Windows user, sorry to say, I dare not to screw things up.
By the way, I’ve double checked the SDS and they show the full capacity and with 2.27 GB unallocated space
checked against the working one that has 1.7 GB unallocated space.

Happy to help Mike. The two blinking lights means that it can see the MicroSD card but there is something wrong with the files on it, so the issue should be with the card and not the pi itself. The unallocated space means it probably flashed to the SD card successfully as the image is a little under 64GB if I remember correctly. I believe if the image itself was corrupted it wouldn’t flash properly. I have the 64GB image on a hard drive somewhere so I will look for it and can check the MD5 for you to compare.

Is it possible that you’re using a Raspberry Pi 3B+ and not a Raspberry Pi 3B? The rachelpi_64EN_4.0.img image doesn’t support the latest hardware and operating system so it won’t boot on the 3B+. If that is the case, the image I’m working on will work as it supports the 3B+ and you can download it from that thread. You just need to unzip it with 7zip and flash it with etcher or win 32 disk imager without needing to do anything in Linux. There is an update coming soon so it’s not final, but if it does work you’ll know that was the problem. I’ll check back when I find the 64GB image to get an MD5 of.

Funny you should say that because I bought first two of the 3B+ to be told the it won’t work with it so I bought
two 3B. They both work with the borrowed 64 GB. No I’m downloading again 4.0 image and hope for the best another two days waiting to see if it’s going to work. It’s so slow to download and even slower to flash the image.
The 3B+ one I used with Noobs and the other will stay until some thing new comes along.
By the way I noticed on previous message I said suppressed but I meant to say supposed stupid predictive text.

Hi James
I had a disaster. I run out of space on the computer whilst downloading rachelpi_64EN_4.0.img.
I run out of space because I forgot I had two other versions on that computer plus the rest of the windows software and this morning had only downloaded 46 GB with low storage space. I did remove the whole lot and \I’m wondering if it might be an easier way of speeding up the download process, or maybe a softer version and add some modules later. The only problem is that I’m not good with Linux commands and I need to have two Rachel Pi servers ready by the 6th of November before we go to Zambia.

Sorry to hear that Mike! I think the best way to get things running in that short amount of time is to use the new image I’m working on unless you’re able to get another SD and test with that will work. I can’t find the hard drive power supply that has the 64GB image on it but I’ll look through some other boxes today so I can get the MD5 for you to compare. Are you using the FTP to download the image?

The new image is only 610mb to download and from there you can install modules from the admin interface when connected to the pi’s hotspot. You shouldn’t need to use linux at all. There is an image file available now that you can flash the same way you flash the 64GB image and it should run. This is the post with the image here. At the top you’ll see a section called “Installation”. You just need to install 7zip for windows, download and unzip the image with 7zip, and then flash it with etcher or win32 disk imager, all within windows. The “Installing Modules” section explains how to log in to the admin interface and start installing. I think you should try it out because it will be much quicker to get going instead of waiting another day for a large download that might not work.

One thing I’ll mention is that the kolibri modules are not working yet. A new image will be out later today or tomorrow that includes support for kolibri instead of ka-lite ( kolibri replaces it ). This image is also untested by the RACHEL team, but it does seem to be working for myself and other people so hopefully it’s stable. The worst case scenario if it fails in Zambia would be having to send replacement MicroSD cards in the future if that happens. That’s the plus side of working with the Raspberry Pi. The hardware is all the same so you just have to send cards to update. If you try it please let me know if you need any help. Hopefully we can get things up and running before you leave.

Hi James
thanks for the info but suspect that have a couple lemon SDS. The reason being that I just finished making a copy of the working SD card and when I tried just some short flashes and then nothing. I made a couple short videos with the LEDs just in case you might know what the mean. The working one goes through A-OK and I can see the RPI on my phone. I’m wondering if there is a place here to upload the very short video of the nonworking SD. This system won’t allow me to upload the short video.
I’ve already downloaded your rachel_pi_10_18_18.7z and Etcher and I’ll try my other SD and see how it goes.
Thank you for your help and I do appreciate your every guidance on this project.

No problem. A site you can use for uploading a short clip is I haven’t used it before but I think it should work. If you can upload them I’ll see if I can figure out what the issue is.

I managed to get the MD5 of the rachelpi_64EN_4.0.img file from 05/26/16 that I had on a hard drive. 7aba20a694e50464fd7c7088cbe4630e is the checksum it gave me and the CRC32 is 3A2ED0F0 ( according to winrar ). I hope that matches what you have,

I’ve managed to flash the rachel_pi_10_18_18.7z and Etcher on another 64 GB SD. I started the Raspberry Pi 3b. The beginning it flashed red once and green twice the red and green once and the stopped for a few seconds and after the red was flashing at deferent rates for a few minutes and then stopped. Waited a bit and restarted, the same again. I checked the card on my laptop and is shows the boot partition 43.80MB with 24.97MB used space, EXT4 2.39GB and 1.85GB used space. Unallocated space 57.96GB.
I think the SDs might not be up to it. Thye cost me around £10.0 each with the adapters. Do you recommend any particular make.?
I compared the MD5 checksum you’ve sent me, however it is different on a previous download and the one that finished this morning.!
I’ve uploaded a .jpg with results of my checsums for you to see.
Let me know about the SDs. I thought about Sandisk ULTRA because this is the type with the working Rachel that I borrowed.
rachel pi checksum|663x229

rachel pi checksum

It looks like your rachel image checksum matches my rachel image checksum for the one that’s 7aba20a694e50464fd7c7088cbe4630e. That image must be good! I think you must have faulty SD cards and replacing them is the best way to go or if you can return them and get your money back that would be good. A lot of the time cards that are in the £10.0 range but are higher capacity ( 32GB/64GB/etc ) are fakes and fail quickly. I use a 64GB Sandisk Ultra that’s grey/red and it’s significantly faster than the other normal class 10 cards for me, so I think going with those is a good option. Unfortunately I think you might have to pay a bit more for a real one. Once you get new cards try flashing the image that matches my MD5 and it will hopefully work. Let me know how it goes!

Hi James
I’ve just received two 64 GB Sandisk ultra SDs and put them straight to work. Both show FAT 32 and one is now getting flashed with my latest download and the rachel_pi_10_18_18.img and it finished quickly sing Etcher rachelpi_64EN_4.img already shows 70%. It proves that my SDs were cheap rubbish.
It seems to work on my Raspberry Pi 3BI can see the RACHEL-PI wifi however when I connected to the router with the RJ45 cable I get no internet connection and I can’t access it with either ip or any other combination. I’ve tried assign it an IP address manually but still no change. Troubleshooting is tells me that it has the the IP is wrong.
Any ideas?
I’'l try the rachelpi_64EN_4.img flashed SD and see if it works and let you know.

Hey Mike,

That’s great that they work. Sounds like the old cards were fakes. There’s a new image out that includes Kolibri that you might be interested in too. I updated my post yesterday to include a link to it and readmes.

The way I generally test is by connecting the pi to my router and then connecting to the ip address that it’s assigned. For me it’s because is the IP address that my router gives it. The ip address is the one that the Raspberry Pi uses for itself, but when connected over Ethernet to a router the ip is set by the router. I would look up how to connect to your router’s interface and see what ip address is assigned. You can also plug your pi into a monitor and when it boots up it will tell you what the ip address is. If you don’t see it there you can log in with pi/rachel and run the command “ifconfig” and look for the ip address assigned to eth0. It should work then.

Great thank you James. I did try to assign it manually but no change. I try something else and let you know. It could be that the router won’t allow it. However, I tried again and managed this time to get in. Does it matter that the connection shows no internet?
I’ve tried to install one module and I’ll see what happened in the morning.
Eycher is verifying the rachelpi_64EN_4.img but is very slow now 35% yet the flash was only a couple hours.

No problem Mike. Once connected to your router your Pi should have access to the internet and anyone connected to the RACHEL-Pi wifi network should have access to the internet as well.

This can be pretty confusing and I think there is a document or video out there explaining how to set up a RACHEL-Pi with a router. This is an example of how it works

  • Phone/Tablet/PC -> RACHEL-Pi WIFI Network =

  • Phone/Tablet/PC -> Router’s WIFI Network -> RACHEL-Pi = http://Address the router gives the pi. ( ex: )

  • PC -> Router using RJ45 -> RACHEL-Pi = http://Address the router gives the pi. ( ex: )

So to make the ip address when the pi is connected to the router as you have to assign it that ip address on your router using the mac address of the pi’s eth0 adapter. You can find the mac using the ifconfig command on the pi. I hope that makes sense.

Hi James
Although last night it did work and windows show the ip address and I think the start address was I did get to the admin of the RACHEL-Pi and tried to install a module. I did exited the Rachel and turned it off. However, when I started it again this morning and the only think that happened was, the green light blinked twice and then once and after that nothing. It did it again after starting and turn it off. Re flashed Rachel-Pi and it did work as I mentioned. I’ll clean the SD and flash again. I’m not sure, I must be doing something wrong. In fact I was going to check it last night but it was getting late and I was too tired.
I try once again and see if have some success. The rachelpi_64EN_4 just finished and it the RPI wi fi is there. If the new flash on 10.18.18. fails I’ll clean and flash the the full version. I can I stop the verification with Etcher in order to save time? Next Thursday we are off to Zambia to set up the computers for the school in Nsobe and we hope that also the full solar panel system will be up and running.
Thank you for your help and guidance so far!!!

Unfortunately I can’t access the command in Pi to find the mac address of the eth0 adapter,
The modules are not populated and I get internal error in the box when itry to install. I think because there is no internet connection and the rest. I think I’ll clean the SD and and flash the full version (rachelpi_64EN_4.img).
I do see the PI wirh DNS and ip

The modules list will say error if there’s no internet connection. I think this has to be something on your router’s end that is stopping it. You could try bypassing the router and plugging the pi directly to the modem you use over rj45 and then connecting to the pi’s wifi with a phone or something to start installing modules.

Is it possible you’re turning off the Pi too quickly after shutting down? The best way to shut down is to go to the admin interface and hit the shut down button and then wait about 30 seconds. On the pi itself you will see it blink the green light about 12 times and then it will be a solid green for about 2 seconds. After that solid green light it’s safe to shut down the pi. MicroSD cards are known to corrupt easily when the power is turned off and is one of the benefits of using a USB flash drive instead, thought it can still happen.

You can turn off Etcher verification. I usually do as it takes too long, but it is nice to know that it worked properly when you’re having problems. If this is not a power down issue, and you have new MicroSD cards, the only other things I can think of is it being the MicroSD card reader you’re using to flash the cards or maybe the pi power supply you’re using for some reason. But that doesn’t make sense if they boot once.

Hi James
I gave up and flashed the full version, I also disabled verification on Etcher. Quick and easy and both SDs flashed and are working OK. When I get time I’d love to get more into Rachel’s workings with a bit of help if that’s ok with you.
Thank you very much again!!