Failed connexion to RACHEL-Pi for some modules

I am currently examining RACHEL for haitian schools in rural areas. I installed the image RACHEL-PI_09_06_2021 on a RPi-4, with 8G RAM. Installation ran flawlessly. I then added modules for testing. Many of them work just fine, but for some others, I get errors such as:

Failed Connexion: Firefox cannot establish connexion with server…

with an address:

For example, this happens with :


It looks like the system is looking for a default language… How can I set the default language in RACHEL? Or is it on the OS side?

Another problem I encountered with some modules is a NOT FOUND error. For example, I get the error message:

Not Found

The requested URL “/mindfield_en_all/” was not found on this server.

when trying to load MINDFIELD 2021.

All modules were installed from the ADMIN Administrator page.

I got the same problem while trying to get to a specific author in BOUQUINEUX:

Not Found

The requested URL “/A/Ebooks gratuits : Gustave Aimard ( EPUB - PDF )_0.html” was not found on this server.

However BOUQUINEUX 2021 works perfectly.

Is it possible that some modules are not fit for the Raspberry environment?

Thanks for any help.

Hi @dco69 - Yes some modules are not supported. There are some important notes on the RACHEL-Pi image downloads page that mentions some of the changes around Kiwix modules and unsupported modules

  • KA-Lite modules are not supported on RACHEL-Pi. LearningEquality have replaced KA-Lite with Kolibri and development/support is no longer available for KA-Lite. Since there are less system resources on the Pi we decided to go exclusively with the newer Kolibri. KA-Lite is still available for the more powerful RACHEL-Plus, which is why it’s still available to download.

  • en-moodle is also not supported on the RACHEL-Pi. It may be in the next images though.

  • There was a change in the Kiwix file format and the tools that use them. To update our modules to use the latest Kiwix files, we had to drop support for the old modules and use the latest tools. With the latest images only Kiwix modules that end in “_2021” are supported as these are all of the new Kiwix format. If you see two modules with the same name you’ll want to install the “_2021” version. I manually rebuilt Boquineux to the 2021 format so I’m very happy to hear that it’s working perfecly :smiley:

That leaves us with the Minefield issue. I just looked and all of the files seem to be correct. Can you try either rebooting or doing the following process

  1. Navigate to modules tab in the admin section
  2. Hide any module and press save
  3. Unhide the module and press save

Hiding/unhiding a module will trigger kiwix to restart. If it still doesn’t work please let me know.


Hello James,

Thanks for the clarifications. I understand now, and things go smoother. It provides one argument for using the Rachel hardware instead of the RPi, at least for some specific situations our team is examining.

On a more technical angle, is there a way to change the port number on rachel-pi? I tried changing the file /etc/apache2/ports.conf, but it is not sufficient. Is there any other file to edit to achieve this? What I have in mind is running both moodlebox and rachel on the same unit (I did it for Moodle-Kiwix-Calibre for a different project), each with a specific port.

Thanks again!

Hi @dco69 - Happy to help. There are a few services running in the background that require different ports. Kiwix, the webserver, and Kolibri. Kiwix is at 81, webserver at 80, and Kolibri is at 9090.

You can edit the webserver port in the Apache2 site configuration file at /etc/apache2/sites-available/default.conf

If you need to change the others it requires a bit more work.


Thanks for the info. I will try that.


1 Like

Happy to help. Let me know how it goes.

Hello James,

I tried again to change the port used by the webserver (default to 80). I edited the file /etc/apache2/sites-available/000-default.cnf and changed port 80 to port 8000. I also changed /etc/apache2/ports.conf so that the system monitors port 8000 instead of 80. When I try to access (or, I get a connexion with the server, but not to Rachel:


I guess there are other files to edit?


The file you’ll want to edit is /etc/apache2/sites-available/contentshell.conf where you’ll see <VirtualHost *:80>. Then you’ll need to restart apache2 or reboot.

Good! I didn’t think about that one… In fact, I had to edit all three: /etc/apache2/ports.conf, 000-default.conf & contentshell.conf to obtain what I want. Everything works now. Thanks.

One thing that our committee is concerned about is the ability to use Moodle from within Rachel. I know that this is not possible with Rachel-Pi, but from what I read, it is possible with your hardware. Is this right? Moodle is somehow the heart of our educative activities, and we would like to bring some courses to remote areas of Haiti. Can we confidently take Moodle courses that were developped on Windows or Linux versions of Moodle to Rachel-Moodle?

With that, I think we would be close to make a jump to Rachel hardware…

Thanks again, James.

1 Like

Hi @dco69 - Great to hear you got that working.

You should be able to migrate Moodle courses to the RACHEL-Plus’ Moodle implementation without issue, as long as you follow Moodle’s import/export process. The only concern generally is the allowed upload size via the browser/PHP. We have increased this up to up to 2GB on the latest RACHEL-Plus device OS, but if you have content larger than that it may need to be increased.

I will be looking at adding Moodle to RACHEL-Pi this weekend when I get some time. I may integrate it into an image or provide a setup package depending on if I can ship with a default email/username or for Moodle or not.


Great!.. Thanks for the info. 2 GB as a max upload size is plenty for our purpose. I succeeded in installing Moodle in parallel to Rachel on a Pi-4. I posted the procedure somewhere on this site, but can no longer find where! LOL… It is not accessed via Rachel though. It is just using a different port on the same Pi. But it works for now. I am looking forward for your implementation.


@dco69 - That’s great. I should be good to get it installed. The only problem I’ve run into is that the setup form requires email credentials and I’d like to avoid using a generic one for possibly hundreds of deployments. I know organizations hate this. Sometimes forms like that can also be too difficult for novice users to complete, or can’t be completed while offline. I may have to ask the Moodle team about that.

The recommended 32 bit Rachel Pi image works fine (details , ).
However, in the non-recommended 64 bit version, upgraded from buster to bullseye,(details, ), the modules cannot be downloaded. .

Hi @geev03 - Welcome to the forums! Thanks for letting me know. Unfortunately the 64bit images are experimental and it’s just not stable yet. I put it there for people who wanted to see the difference or try, but it’s the exact same installation as the 32bit version so most errors will be with the OS and packages itself.

I will be putting up new images soon, so maybe the next one will be a bit better.