GCF modules downloads with multiple videos that are the same

This is a conversation we had with @jamesk earlier this year @jeremy . You gave a script so that we could use the host device as both a server and a client. However when the module GCF is compiled there are duplicate videos in the /var/www/modules/en-GCF2015/content/ref_videos directory. I have attached a screenshot of what im seeing. It has almost doubled the size of what this directory is suppose to be. videosRachelGCF


Also @jamesk do you think there will be any issues with the python 2.7 being discontinued? When running the script python no longer works. I was able to run it with python3 package but still getting errors involving syntax and other packages downloading

1 Like

Hi @david.gomez – that module in particular is maintained by the GCF Learn Free team directly. I will let them know and see how they want to handle it. Thank you!

Ok thanks @jeremy. Looking forward to hearing from them!

Hello @david.gomez,

Are you installing en-GCF2015 through the admin interface or downloading it from oer2go.org?

I just checked the world possible server copy of en-GCF2015 by listing the files and there are only MP4 files. That’s what gets installed when you install modules through the RACHEL admin interface. The only way I can see FLV files being there is if the oer2go copy has them or some local utility installed is converting all of them. I always recommend using the install page because it gets the latest version.

I think the only python specific issue with the install script that needs to be changed is around the print function which prints out messages. It just needs parentheses so


instead of

print "something"

I have changed that in recent RACHEL-Pi installation scripts. The main issue with installers is you can’t really predict what packages will be changed and what is removed on their end. Sometimes they add new settings or warnings that you have to automate a response to. When PHP gets updated the path for stem.so changes, sometimes php code has to be changed, etc. Even though it’s automated it’s still very specific to the date it’s run and I don’t think there’s a way around it. If you ever need an updated installer just let me know and I’ll look at it. I’ll update the installer today and let you know when a new one is up.


Hello @jamesk

Im downloading en-GCF2015 from the oer2go.org. I am not able to use the admin feature. I think had to do with how we are using Rachel-pi with the script. In order to update the modules we have to run the script again, and it looks like it delete the directory and reinstalls all modules.

So you are correct, I just changed the print functions that were in the script however I was able to downgrade to 2.7 but I had to update /var/apt/sources.list when using 18.04.3. I think the issue (besides the parenthesis when running the script with python3) had to do more with the sources.list not letting me apt-get packages. If you do update using python3 I would love to use the script. Thanks again James!

The en-GCF2015 issue is likely with the oer2go.org module zip then. The FTP and probably oer2go zipped modules have some issues like doubled content and embedded duplicate folders but that looks like it might have been left in when transitioning from flv to mp4 or something.

Are you using some other process than just the Ubuntu install script to install RACHEL to these devices? I tailored the installer I posted specifically to the latest Ubuntu LTS at the time and made quite a few changes to support Ubuntu so there shouldn’t be anything involving the RACHEL-Pi. I still have the Ubuntu VM I tested with and just now tested installing a module and it installed properly. I think it would be best to figure out why that’s not working for you.

Okay so I’ve updated the Ubuntu local installer. There weren’t any changes required for it to install but I changed the print() function, updated to the download the latest Kiwix, and made a few minor changes. I tested with a fresh installation of Ubuntu 18.04.3 using ubuntu-18.04.3-desktop-amd64.iso.

  1. Install Ubuntu 18.04-3
  2. Open a terminal and run the following commands
  3. sudo apt-get update
  4. sudo apt-get upgrade
  5. sudo reboot now ( to reboot the system )
  6. Download ubuntu_local_10_08_2019.zip
  7. Unzip it and place the installer directory in the /var/tmp directory
  8. Open a terminal and run the following commands
  9. cd /var/tmp/installer
  10. sudo python3 installer.py
  11. When the installation completes run “sudo reboot now” to reboot the system

That should be it. When you reboot you should be able to access rachel at http://rachel or http://www.rachel.com. If you click the admin interface you should be able to log in and install modules if you’re connected to the internet.

Thanks a lot, @jamesk will try it out now and tell you how it goes. Also, should I be able to use the admin feature on the browser to manage the modules or will I have to run the script every time I want to update the modules?

You’re welcome. The script is meant as one time thing for the initial installation. It expects a fresh Ubuntu installation. It only installs 1 module, en-kolibri-index, for accessing Kolibri. When you navigate to RACHEL in your browser you press the admin button and then log in with “admin/Rachel+1”. Once logged in you can install modules from the Install tab. You can update those modules from the Version tab if they’re updated on the RACHEL servers. The supported modules is the same as listed in this readme PDF. en-file_share isn’t included because it’s a local installation. Let me know how it goes.


Yes this worked perfect. Now I can delete the installer after initializing Rachel. The admin button worked with this one!

Great. Glad it worked.

RACHEL on PC is up and running in Siavonga!
Great work @jamesk

1 Like

That’s great to hear! Was it installed to laptops or to a single server?

Hi James,on a laptop, I used Ubuntu 18.04. It is also running Kolibri.

The only addition I would like to see is the IP address on the banner. lol

I have tried to put RACHEL onto Raspbian but Raspbian has php7.3 installed and the installer fails to find php7.2-common
When I tried
sudo apt-get install php7.2-common
I got
E: unable to locate package php7.2-common
E: couldn’t find any package by glob ‘php7.2-common’
E: couldn’t find any package by regex ‘php7.2-common’
So for Raspbian I,m sticking with Kolibri
Kind Regards

Hey Howard,

RACHEL gets the IP Address from the output of an “ifconfig” command if it’s successful. Can you run “ifconfig” and paste the output here for me so I can see what it’s expecting? the RACHEL code looks for “eth0|enp2s0” on Linux but it might be different on your system.

Are you looking to install on Raspbian Desktop or Raspbian for the Raspberry Pi? The installers have to be tailored for the exact OS and can’t be used on different ones without being adjusted. The ubuntu_local installer installs Kolibri and the en-kolibri-index module as well and is meant for X86 systems…


Hi James, I was trying to set-up RACHEL on the Raspbian for desktop on Fujitsu Lifebook laptops, I hope to install RACHEL on whatever i386computer the school has. The current IP address is
We want to use Raspbian Desktop because we use Pi4 as the desktop PCs in many schools and want a degree of consistency.
I would also like to be able to set-up DHCP on whatever computer we can use, even the Pi. If this is easy to do could you point me in the right direction. Thanks for all your hard work.