Help! "Internal server error" when uploading content

I have uploaded many docs to my older RACHEL-plus devices. Just getting started with a new RACHEL-Plus 3.0. When I try to add content I get a red “Internal Server Error” message. I have rebooted the device, tried uploading content from 3 different devices, and have tried PDFs and JPEGs. Heading to South Africa in less than a week. Please assist!

“Internal server error” - some additional info: In the Admin panel, under the Install tab, in the box under “Add modules” it says “Internal Error”

And when I click to delete modules, they do not get deleted.

Please advise.

Hi @bobrollins – this is still a symptom of the booting issue we are having. More info here: RACHEL does not restart after first power down

It seems I couldnt load the content neither in the Lesson Planner nor in the Moodle. So far I am facing the following challenges:
a. WIFI failure after rebooting. However, using a Keyboard and Pressing Ctl + D ressucitates the Wifi signal
b. Failure to upload content in the Lesson Planner
c. Failure to upload content in the Moodle
I am stuck because my work involves curating content and uploading it into RACHEL for students to access. I hope someone in your team can sort me out fast. I am yet to try creating modules though I have thousands of contents.

Thank you, to WP’s Steve Bashford who worked hard to get this fixed. If anyone out there sees “Internal Server Error” on a red background after trying to upload files, it’s time to email Steve.

@jeremy @Steve
We are also seeing the “Internal Error” in the admin module view, but haven’t experienced the problem with re-booting or dead WiFi. But this error apparently prevents us from uploading our locally created modules. Any suggestions? I’m downloading the latest USB recovery image (been at it for 5 hrs and 23% complete so far) but before I take the drastic step to wipe and re-image, is there anything else we can do to remove the “internal error”?

Hi LeonA,

Please clarify. You are attempting to upload local content. OK. To where:

  1. Admin->Install
  2. Local Content module
  3. Moodle

Are you able to provide a screen shot of the error upon upload attempt.

PS: Thank you Bob for all of you hard work…

1 Like

Hi Mbogo,

I would like to assist in getting you back on track. You still have these open issue?

a. WIFI failure after rebooting. However, using a Keyboard and Pressing Ctl + D ressucitates the Wifi signal
I have provided a filed update for this issue and am happy to help if there are any snags.

b. Failure to upload content in the Lesson Planner
I have a fix available for this issue.

c. Failure to upload content in the Moodle
I would be happy to work with you to resolve this issue

I can’t attach screen shot from this computer right now, but will manually paste from my other PC connected to the RACHEL+3.
ADMIN -> Version:
RACHEL Installer = 3.0.0
Content Shell= v2.3.7
ALL listed modules show their version number, followed by a box with red letter “X Internal Error (4)”

INSTALL -> Add Modules:
Box shows "Internal Error"
Currently Adding:
ALL modules show their name, then red letter “failed” and a “0”

We developed our own module using themodified rachel-index.php template and created our index.html and appropriate content files in a folder named “en-xxxxxx”, then go to Admin-Install - Add Modules - Advanced and upload “Choose File”. Browse for the folder and click install but it fails. I also tried copying the module folder into the ‘/media/RACHEL/rachel/modules/’ location and browsing for the index.html file (also the rachel-index.php) but always fails.
The “errors” don’t seem to affect using existing modules on the device, but we can’t add our own modules. However, we CAN add “local content” files in the other teacher/teacher admin mode.
P.S. the CAP3 USB recovery file (2GB) is still downloading on the other PC (40% complete after 7_+ hrs --that must be a really slow server).
Leon for IEI Liberia

OK. I can help. The upload you are using isn’t for uploading modules, but for module lists. I suspect when you attempt to upload a module, the device attempts to run a previous list of modules or unknown names and all fail.

At this time, there is no simple GUI to upload modules to the device. Developers have used utilities like ssh. However, I have a procedure and basic script that will make it a bit easier. I will post it within a few minutes and provide a link.

1 Like

Download this file, unzip it and follow the procedure to load modules onto your Rachel Plus device:

hi Steve,

We are having issues installing modules from the Rachel “install” tab. For example, we try to download Kolibri and it displays a zero before alerting the download failed followed by an internal error message. Do you have any advice on how to resolve this? Thanks!

Hi Ian,

Currently, there are no kolibri channels available for download using the Install tab method. You may see en-kolibri listed, but the zero download status just means the content is not available.

  1. You are attempt to install on a RACHEL Plus device?
  2. What is your “RACHEL Installer” rev (see version tab) 3.x.x
  3. What is your “Content Shell” rev (see version tab) v2.x.x

RACHEL Installer = 3.0.2
Content Shell= v2.3.7

  1. Is Kolibri currently installed?
  2. Are you trying to add additional Kolibri content, and/or update the Kolibri app?

Thank you

Hi Steve,

Thanks for your response. We are attempting to install on a Rachel Plus device. The installer is 3.0.2. Our content shell is v2.4.0.

Kolibri was installed, but it was showing the module as if we didn’t have it on our device already. So I thought it could be a module with even more content. But when I went to install it, it failed, and now Kolibri isn’t visible on our device, even though it’s still installed.

We do want to add additional Kolibri content. One of the main goals in our classroom is to track individual progress, and Kolibri allows us to do that well. Though, I’m open to other ways to track individuals who use our Rachel. As far as I know, they cannot be tracked individually across different modules. Please correct me if I’m wrong.

Thank you!