Internal Error - Admin Module Install and Update

I have completed updates and installed modules before. For some reason I keep getting these internal errors. I tried downloading a module right from OeR and install on RACHEL plus, but that didn’t work either. I am not sure what to do? It is the 2.0 version.

Chrissy46 PM


From the screen-shots, it looks like you are connected to the Internet (via Ethernet cable to your router). Next step, please click on the “hardware” tab and verify you have storage space available for the downloads.

Hi Steve,
21 AM

Looks like I have plenty of space. I tried doing the update and installing a module and it gave me the same internal error.

Any other ideas?

This is the message I get:

en-siyavula failed0
command: rsync -Pavz rsync:// …/modules/
runtime: 2:32 failed
files_done: 0 out of 75 ( 0% )
data_done: 0 out of 1013764 ( 0% )
data_rate: 0
latest output:
rsync: failed to connect to ( Connection timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(128) [Receiver=3.1.0]

Hi Chrissy,

The last message that you provided shows the device is not connecting with the server for download. I checked download on a device and laptop with no issues. Next thing to consider: You may be behind a firewall or router blocking the port needed for rsync to run. Are you in an office where IT may have changed policies since last downloaded, or somewhere you haven’t downloaded from before. Are you able to try another location, like home router…?

Hello! I am experiencing the exact same issue (internal error) when trying to update.

I do have storage in there (only 1% was used).

The model is WAPD-235N

Please advise. Thanks!

Hi Bob – this means the device is not getting an internet connection. You have to plug the device into the internet using an ethernet cable plugged directly into your home router or modem. Have you done that?

Here is a video on how to accomplish the full process: