KA-Lite admin password RACHEL-Pi 4.0

A user wrote in:

Hello All,

I am adding this message to Justin’s original thread.

In my case I installed rachelpi_64EN_4.0.img on the recommended 64GB micro sd card and have plugged it into a Raspberry PI 3. Both RACHEL and KA-Lite come up fine on tablets and laptops using the default WiFi SSID: RPI and browser IP address:

I can sign up as a student on KA-Lite, but try as I may I am unable to login and access KA-Lite as an Administrator. I have tried using the root/rachel and the other user/password combinations you listed to no avail.

I realise that some aspects of KA-Lite cannot be edited on this embedded version of RACHEL, but the 64GB RACHEL 3.1 User Manual states that I should be able to access many of the administrator features such as adding teachers students and groups, and viewing the progress of students in those groups-- what am I doing wrong?

I would appreciate any help!


Sorry, we will make sure to better document these going forward. I don’t have a running system in front of me, but I would try the following:

rachel / rachel
root / rachel
admin / Rachel+1
teacher / teacher

Please report back here if you have the answer.

If you’d like to change this, I believe via command line you can enter:

kalite manage setup

rachel / rachel

is the current username / password for the KA-Lite admin account

We have a default password page here - but maybe it needs to be updated?

Updated now @jfieldtest

Thanks for your quick response!

rachel/rachel works fine for the KA-Lite admin.account.

When I log in as admin, i am asked to register a facility, but this doesn’t make sense in our case,. These Raspberry Pi units will be installed at several remote rural schools in Uganda where no internet is available. Is there any way to eliminate this confusing message?


I agree but we can only report that issue to the ka lite team. What happens if you create a facility though? Understanding you have no internet.

I am evaluating the Raspberry Pi 3s with RACHEL 64GB now in the USA prior to the final deployment at the Uganda school, so I currently have internet access for downloading and testing RACHEL.

To answer your question, I just went online with the Pi’s LAN connection and attempted to add a facility by logging into KA-Lite as admin. Curiosity must have killed the cat because I was connected to a central server somewhere and was provided with an actual facility code: “Zone for Public Key XXYYZZ …” complete with someone’s real pre-assigned group and teacher’s names! I decided to abandon the attempt and immediately deleted the facility.

I then went offline and logged into admin. This time I received a “You currently have no facilties that sync data with the central server” message. I went ahead anyway and clicked on “+Add a new Facility…” ignoring the “Search for your facilities address …” window, I saved my new facility name as"Test".

I guess assigning a facility name offline works well enough for now, but it seems that I can’t get rid of the “Zone for Public Key XXYYZZ .” facility name that was assigned after my initial online attempt.


I wonder if that public key is perhaps something we might have done on our end before we created the image file. We will investigate…

I would be interested in knowing what you found out because I’d like to link KA Lite on our RACHEL plus devices with my online account but I get the same automatic public key with that user information pre-populated. I deleted the location also and the device registration. When you ‘register device’ it’s supposed to give you the option to login to an online account (I have one) or not, but that option isn’t there for me.

I did see this workaround on their site but haven’t tried it yet and don’t know if it would work on the RACHEL plus.

@joshuawagner I didn’t find a solution to this unfortunately.