Kolibri on Rachel

Hi my name is Maina from Kenya and using Rachel Plus 3.0 in our centre. Problem am having is that i cannot create users, coaches or learners on Kolibri currently since repair of the devices. (Before we had done so).

Am not sure why this is so but maybe someone there can help me.


1 Like

I will try to reproduce the reported issue and let you know what I find. Are you able to get to the kolibri page from the kolibri index page (see below for kolibri index page A & B)?

Are you able to attach a screen shot of the issue?

Thank you.

1 Like

Hi Sir,

According to the attached image, we can manage to go through only that the first person who signed in as an admin, that was all. Now what the problem is, From there she only can manage to create classes, but no coaches or learns can be added. I’ve attached images for you to see.



1 Like

Hi Maina,

I hope I got your inquiry. You just want learners and other coaches to be able to create their own profile and use their account.

You need to change settings on your kolibri system

Here’s how you go:


Then, you will have to save changes, log out and your kolibri home screen will look like this


Probably, you were given access to login as admin only. Just play with the settings to facilitate your needs, May be you aim students to login to their account to track progress instead of continue as guest

All the best and let us hear any queries you might have.



1 Like

Hi Jseni,

Thanks for the concern.

I’ve tried all of this but still nothing is possible, even changing the admin profile has got issues. We are only able to use the Kolibri normal we can’t track students progress, add any coach or learns only classes. Now here in Kenya students have started coming to the centre but we have no way of tracking or assisting them on the device since of the above issues mentioned earlier.


1 Like

Hi Maina, I encountered the same problem after updating my RACHEL Plus version 3. Unfortunately there are a couple of gotchas when you log in as admin, click on the Version tab & Check for Updates. When things work, the Content Shell will show v2.3.9, but RACHEL will tell you that v2.3.8 is available.
That seemed to be the beginning of my problems. It also recommended I upgrade my en-kolibri-index from v0.3 to v0.2, which is also a step down, not a step up.
Right now I’m pretty much stuck here. I did manage to upgrade the Content Shell back to v2.3.9 but I have not been able to upgrade the en-kolibri-index back up to v0.3. I suspect once I am able to do that I will need to uninstall Kolibri & then reinstall it, which I’m not looking forward to as it took over 3 days to download and set up all of the Kolibri channels last time I did that.

For what it’s worth, I have 6 RACHEL Plus version 3 devices & 5 of them are working. The only one not working is the one I tried updating when I was in a hurry & I didn’t notice the discrepancies I pointed out above.

I’m trying to work with Steve on this, but right now I’m waiting for the next step also.
Check your content shell version & your en-kolibri-index version & see if they are at the correct level.


1 Like

Hi Larry and Maina,

Laura here from LE. I shared this with Maina over e-mail, but I’ve become aware that this could be a browser related issue if you’re using IE or Edge. There’s a GH issue here that explains more, but a fix was implemented in Kolibri 0.10 to hopefully resolve this.

Can you confirm what browsers you experienced this on? If using IE or Edge, I recommend upgrading to 0.10. I’ll gladly PM you with the instructions for doing that.

1 Like

We are Facing this similar issue in Screenshot B with Kolibri On RACHEL Plus. How can it be resolved?

Hello @Denise_Grandoe - I’ll try to help you with this issue. Can you please provide the following information about your device.

  1. Log in to the “admin” page and navigate to the “version” tab and provide the Kolibri version

  2. With a device connected to your RACHEL-Plus over WIFI, navigate to and tell me if Kolibri is there.