Loosing WIFI connectivity on Rachel Plus 3.0

Hi, I just purchased a Rachel Plus 3.0 here in Fiji and I am having issues loosing WIFI connectivity after using it for approximately 30 minutes. I have to restart the Content Access Point module to reconnect through WIFI. Would like to know if anyone else faces the same problem.

Hi @mataiwq – I’m sorry to hear about this! We haven’t heard of any reports like this yet.

Does this happen from multiple different ‘client’ devices? What devices are you using to connect to RACHEL?

Does the WiFi signal become not visible to any device or can you see the WiFi signal and just not connect?


Hi Jeremy, for both my notebook (windows 10) and on my phone (S5)

Very strange, I’m sorry to hear about this. My only initial guess (and it’s just a guess) is that the RACHEL unit might be overheating.

Do you have a router around you can connect RACHEL to? I’d be curious to know if the whole RACHEL unit is locking up after 30 minutes, or just RACHEL’s WiFi. Do the lights stop flashing when the WiFi goes down?

The lights continues to flash but its seems to be heating up on the underside (not very hot) and I thought its normal

Yes, it’s normal to get a little warm. You can try connecting the device to a router and seeing if you can access it more regularly without disruption. RACHEL-Plus on a LAN or with Router

OK I will try that and let you know

Thanks, we will want to figure out what is going on regardless, but that will give us more options to troubleshoot also.

Hi Jeremy,

We purchased two Rachel Plus 3.0 and after four days they both lost the Wi-Fi signals too. We are in Kenya and i was wondering how i can fix this problem maybe by logging into it and see what is the issue. Is there a way i can do it via LAN? What are the I.P address to use to do it?


Hi @myce

Sorry to hear you’re having problems. I think your issue sounds different than this from the original poster.

You can find your RACHEL on a router here: RACHEL-Plus on a LAN or with Router

Please note, that the IP address will be assigned by the router itself so I can’t tell you what it will be.

There is an option in the admin panel of RACHEL to “turn-off WiFi” – is there a chance that someone turned off the WiFi there?

When you reboot the device, to the three blue lights on the front move to “breathing” or slow pulsating?


Well thanks for your advice, i followed the instruction still no responce yet even on the router. I even inserted the LAN direct to my computer and no connection it kept saying indentifying …
Jeremy, at this centre, we go to the villages where there is no power with the rachel coz of the intranet support so even connecting it to a LAN won’t solve our problem. My request is how to get into the router and check the settings coz blue lights are not breathing, pulsating or even lighting up only a small one on the power burton and you can feel the harddisk working.
We are using the new rachel model with two 3.0 LAN ports.

Thanks in advance.

Hi Myce,

We are finding a small number of Rachel Plus 3.0 devices were configured is such a way which ultimately resulted in an inability to reconnect to the Rachel Plus device after rebooting (~1-3x). Unfortunately, we do not have a field update at this time (though currently working to identify a field update solution). At this time, you may (a) provide us another 1-2 days to determine if we are able to develop and provide a field update, or (b) send the device back for reconfiguration.

If returning for reconfiguration, please:

  1. Ship to: 5151 California Ave, Suite, Irvine CA 92617
  2. Send an email to steve@worldpossible.org
  3. Include your full name
  4. Include the return tracking number
  5. Provide your order number (if possible)

We will expedite the necessary steps to ensure your device is:

  1. Reprocessed with the latest updates
  2. Passes our latest diags (which now includes multiple reboot & Wi-Fi connection testing)
  3. Returned expeditiously

Finally, I apologize for any inconvenience this issue may have caused.



1 Like

I had what sounds like the same problem as well … Symptom

  • I could see the Rachel in the Wifi drop down
  • Connecting to it failed.

Turned out it was not providing a DHCP address, on a Mac this shows as a “!” in the Wifi and when I open Network Preferences it shows “Self assigned” IP address.
My fix was to manually set my IP address to and router then connect as admin, and go to the DHCP screen, change DHCP off, Save, Change it back on again and Save again, at this point it worked after it restarted.
I may be miss-remembering this somewhat, it was only my second time on the Rachel.


Hi Mitra,

Thank you for the info. The issue described above was ultimately a FS corruption issue which resulted in device boot failure (subsequently, no WiFi led…). There were a few dozed devices exposed in the field. We have addressed all known cases at this time. If there are any future instances that match your info, I will be sure to leverage it. Thank you for the info.



Hi, I received my RACHEL in early May and have been having a problem with connectivity, and as a result, turn-off.

The 3-tap method for turn-off only ever worked once, and the 1-tap never, so I’ve been shutting down via the Shutdown button in the Admin area. But this only works if you’re connected. Yesterday the screen displayed the normal “RACHEL is shutting down” message, but it never did turn-off. And although RACHEL appeared in the WiFi drop-down list, I couldn’t reconnect.

Previously, whenever there was a connectivity problem – perhaps a quarter of the time (I should have kept a log, is this frequency normal?), I’d have to let the battery discharge, but once it was recharged it was possible to connect and seemed to work normally.

This time, even with the unit recharged and the WiFi light slowly pulsing and RACHEL appearing in the WiFi list, every connection attempt has failed. Presumably due to the faulty shutdown yesterday.

I did have an experience last week where I’d been recharging for about 45 minutes and tried to connect, but couldn’t get on, even after another 4 – 5 hours of charging. At the time I thought that my premature attempt to connect might have disrupted something, though this seems illogical; is it good practice to try to connect while charging is occurring? (I’ve never charged for more than 6 hours as per instructions. Pity there can’t be some sort of LED light to indicate full charge.)

I noticed that Mitra solved his connectivity problem by turning the DHCP off and on (November 2018). Is this the only way? I looked up the acronym, but have no clue how to do this. (Steve commented to Mitra about an FS issue, but I have no idea what this means.)

I’ve been hoping to ship the unit to Laos, but have had a crisis of confidence.

Any ideas? Thanks, Paul

1 Like

Hi Paul,

The symptoms which you describe do not sound FS (file system) related. I believe Jeremy has made initial arrangements with you off-line via email to get you going again. Once I inspect the unit upon return, I will be happy to post any info to this board which may be helpful to others.



1 Like