Moodle Error after Content Shell Update

After changing from Content Shell 2.3.0 to 2.4.0 Moodle was no longer available and producing an Error 404 not found. Who can help?

@Steve – any ideas here? @rodiwv – how recently did you get a contentshell 2.4.0 update?

thanks for looking into this - just done the update a week ago then I encountered the admin issues on Moodle. I can now get back to moodle, but when I login as admin (standard pw) I always get the error message grafik whatever I do.

I’ll check the changes. Content shell 2.3 -> 2.4 only adds an upload form for a new feature. Other than adding a simple php script, used during upload and adding the form view to the settings tab, there is no code that would affect any other function. Clearly something changed. I will review and see if there is anything that I could have missed.

Please confirm you updated from 2.3.0->2.4.0 (or 2.3.9->2.4.0)

I did a side-by-side comparison between content shell revs 2.3.9->2.4.0 (most recent change). There is nothing that could have affected moodle from this standpoint. I will update a device from the OER2GO and see if I find anything.

If you truly updated from 2.3.0, I will need to look through all related revisions. Please confirm. Also, (a) were any other updates performed? Has moodle very recently been used, indication of correlation between content shell update…

yes I think it was 2.3.0. I also deleted Moodle from the server and loaded it again from your ftp site. You can check in directly in my server via if that helps

So after the update, you had to delete moodle and reinstall to get it to work again, it appears. Thank you. I’ll keep working on replication and resolution.

OK. Found it. There was a link dropped from the content shell at some point. I’ll resolve the issue and do a postmortem to fix related process hole… Net, when moodle is reinstalled, it recreates the link.

wow, well done - do I have to reinstall Moodle in this case?

Thank you. If you have content in moodle, no need to reinstall. I think I can use the new feature (just released on 2.4.0) to fix the issue. I am validating the process fix and then will work on an update utility. However, if you don’t have content on moodle, reinstall will be the easiest. Please allow me to complete the validation over the next few minutes.

I have validated the contentshell update. It now preserves the moodle link. If you don’t have content loaded in moodle, the simplest thing to do is download moodle again. Otherwise, please let me know and I will provide an update utility to resolve the link. You can load the update script to the rachel device from any client that is capable of connecting to the rachel interface. Note however, the first time the feature is used, the device must have access to the internet.

sorry, the error persists. I do have internet connection and reinstalled Moodle. Now even the user platform returns the error message.
I also have tried it with Microsoft Edge and get the same results. My server would not reload the 2.4.0 contentshell as it indicates to be on the latest version.

Sorry to hear. I will help get you going. But first, I follow the link you provided and moodle does come up. It doesn’t for you following the same link? Please confirm. Also (following the link), I see version 3.0.2. Is the other rachel, originally showing the “Coding error detected” also version 3.0.2?

Thank you

true, sometimes the moodle comes up on the user platform - but when you then go to Login with admin and Rachel+1 the error message is coming back. Under Admin nothing is operational so Moodle can not be configured. Sorry can not find the Moodle Version but the same error occurs on my other server that runs on 2.3.9 content shell.

Understood. More than one device exhibiting the “Failed to unserialise data from file” issue. I haven’t seen this failure message on a RP device before, nor been able to replicate it, at least so far. However, the message indicates a somewhat common issue to moodle (apparently). I am working on providing a script. Meanwhile, if you are ssh savvy, you can run these commands from the cli on the device. Basically unlocks any associated locked files and clears moodle cache/cache files and doesn’t run risk of mis-configuring anything…

php /.data/RACHEL/moodle/admin/cli/purge_caches.php
rm -r /.data/RACHEL/moodle-data/cache/*

tried but was I was unable to clean the cache with SSH. I noted on SSH root entry the message that 261 packages can be updated with a run command “do -release-upgrade” - should I do that? It warns me afterward that the fitrewall should be switched off for this to work properly. I did not do the update.

When you say that you were unable, what was the output? One command clears a file and the other deletes temp files from a dir. There would only be permission/ownership preventing such commands. Thank you. Oh. Yes. I wouldn’t do any updates or anything that changes the landscape till the issue is fixed. We don’t want to add additional variables into the mix.

Also, I see that moodle is working on your link. I tried logging into the admin area and trying moodle again. I can’t replicate the issue on this device. Is there another step? Thank you.

many thanks, all is now working fine - after cleaning the cache with SSH above it gave me access to the admin section.
For proper file uploads I also had to change the php.ini file to allow uploads of files larger that 8MB.The file is found with Filezilla - root etc/php/7.0/cli/ and needed to change post_max_filesize = 1024M as well as upload_max_filesize = 1024M
i.e I have now been able to integrate .mbz course folders and it works beautifully - sample guest access course It also connect to my iPhone where I can download the entire course. So its a great tool for all levels of education!

1 Like