Rachel on a raspbery pie zero w

Hello to everybody.
I have just discovered the project this amazing project.
I wanted to know if the option of using the raspberry pie zero w has been discussed.
It has the wireless capabilities of the pie 3 but it costs much less and it is also less capable in processing.
Let me know what do you think

Hi @Ilan this should work fine, we haven’t invested resources in this yet either, but it should be a very easy port from our raspbian based script: https://github.com/rachelproject/rachelpiOS

Would you like me to check if it possible ?
this could bring your pi server prize down by 25 usd i guess and make it more accessible.
I currently don’t have a pi w thow…

@Ilan that’d be great. I don’t have a pi zero either, but if you buy one, and do the work, we’d be happy to reimburse you the cost.


Ok I will check how much it is to send it to my country and let you know :slight_smile:

I was able to get it working just fine on Pi Zero W. It was pretty simple all I needed to do was update the dist. And it worked right out of the box.

It’s a bit slow and has trouble handling more then a few computers but it works pretty well on such low power.

I also disabled the LED’s and the HDMI Interface to safe a bit more power.


Hi there. I just got a Pi Zero W and managed to ensure it was working correctly with Rasberian NOOBS OS without problems. However, I can’t get it to work with the current Rachel 64GB images (that are working/running on a Pi 3 B). Can you explain what is needed to make the Pi Zero W boot? When I insert the Rachel SD Card and power up, the green LED doesn’t even flash, indicating (I believe) that it doesn’t like the image.



You will need to use one of the updated unofficial images I’ve made that you can find at this post here. The 64GB RACHEL images are not compatible with the Raspberry Pi 0 W by default as it requires a newer OS and many things have changed since then. The best method is to flash one of those images to a Raspberry Pi 2B, 3B or 3B+ and then log into the admin interface and install modules from there. You can then take that card and put it into your pi0w.


1 Like

Thanks for the information! I’ll give it a try and see how it goes, no problem. I’ve been working with a French build, but using Wordpress for the interface, and adding my own content (books, videos, etc.) through the WP interface and it’s been working great (once I figured out all the issues with performance). We using it in primary schools in Senegal …

You’re welcome. These images are a work in progress and will be updated soon. The first goal was to get RACHEL running on the new pi Hardware and OS but they haven’t been optimized so the performance on the pi0w might not be the best. I will probably switch to lighttpd after everything else is working properly. These are unofficial but I hope the RACHEL team will put host some full images with content in the future to make it easier for the pi0w.

Are you looking to make your own server? I can give you some advice on getting better speeds out of the pi0w.


I was reading a little about LightTPD ( https://pimylifeup.com/raspberry-pi-lighttpd/) and it looks pretty straightforward. I like the idea of having php 7 as well, actually. I tried running some other code recently that required it, and had problems. What’s the advantage over Apache? My “use case” is for a webserver with 30-100 students in a classroom. They aren’t all accessing it at one time, fortunately, but they are doing a mixed workload of videos (primarily KALite French), wikipedia and downloading pdf books to tablets.


The hope with Lighttpd is that it will take less memory which is limited on pi devices. The current images use Apache2 and mod_php because this is how it was previously set up. I did upgrade it to php7.0 and it seems to run well. Server configurations isn’t something I’ve had time to get to so I haven’t tested them all but I have tested with apache2 using FCGI php-fpm and it seemed pretty much the same. The issue with switching to lighttpd is making sure all of the modules and search functions work. I think the RACHEL-Plus uses it though.

30-100 students will be hard to support with a pi. I think the max you might be able to get when serving video to a class is going to be between 10-15 per pi with the 3B or 3B+. I have no idea how many students a pi0w can support but I think you would need one for every 5 or 6 tablets. You might want to test that out. @SHOMI is doing a French deployment in Haiti with Pis so it might be worth asking him how he set up their deployment. Installing Ka-lite on these images requires a bit of extra work right now because the finaliization scripts on the RACHEL rsync servers are out of date for the pi and there is a script I fixed for french ka-lite that is in the main image thread.


@jamesk – thanks so much for continuing to plug away at this. At least folks can appreciate how much work goes into this with all your work! What’s wrong with the finish install scripts? Did the rpi directory structure change?


Thanks Jeremy! I’m happy to be contributing.

I found that the finish_install.sh scripts fail when installing through the admin interface for a few reasons.

An invalid pidir. For instance


where it should be


Use of the double brackets like this

if [[ -d $plusDir ]]; then

which is an extension that doesn’t seem to be supported. The solution was to use single brackets

if [ -d $plusDir ]; then 

Restarting ka-lite on the wrong port.

kalite restart --port=7007

while for the RACHEL-Plus it would use the default port with a simple

kalite restart

This is an updated finish_install.sh for fr-ka-lite that seemed to work for @SHOMI here. It was run as sudo over ssh though.

The newly implemented script for the en-file_share module also fails. I think that may be a permissions error as it changes the permissions on the uploads directory afterwards but I haven’t looked yet. How are the permissions set up for these scripts to run? is there a rule added to sudoers for a specific path?


I downloaded the smaller french KALite package, and then the install script (sudo ./ finish_install.sh) and then the language pack (english) from the KA lite admin page. That all worked. The KA Lite practice files worked, but was missing the instructional videos, so I also downloaded those from the Admin/Videos page.

On top of that, I’m using Wordpress and a lightweight WP Theme (“Education Mind”) that doesn’t make calls to the internet. I’m also using a caching Plugin. Installing mysql was no problem and seems to work well with php 7.

However, I also edited the “wp-config.php” file. This is supposed to block external requests (trying to get to the internet via calls can cause terrible performance issues, as your Pi will have no access to the internet). However, you may need this block commented out while configuring Wordpress during theme updates and plug-in downloads, etc. However, it’s best to find Themes and Plug-ins that “DO NOT” make external calls (you often see external calls for google fonts, for instance).

/** Block external requests */
define(‘WP_HTTP_BLOCK_EXTERNAL’, true);

Anyway, for now I have a nicely performing Pi Zero W build running.


Hello again. I downloaded all the KALite French videos, and the navigation shows up correctly (at and when I go into KALite Admin, I downloaded all the video via their interface. It now shows that I have everything. However, the Rachel homepage and associated links (mapping) to the “Math by program” isn’t working. The links like this: seem correct from my other KAlite installs, but the page isn’t found (error message below). I believe the content is there, because I can see all the Math lessons from the “Math” section, such as --> Bases en calcul. Any suggestions on how I recover/find these links/content?

“Ce contenu n’a pas été trouvé ! Vous pouvez le télécharger en allant sur la page Gérer > Vidéos.
Unavailable Content
This content is unavailable. Either it must be downloaded, or the url is incorrect.
Sorry, this item has not been downloaded.”

Math Par Programme

Hi manno,

Glad to hear your server is working. I’m not really an expert with Ka-lite. I think the proper method for downloading KA-Lite content for RACHEL is to use the admin interface and not the KA-Lite interface. You can try running the finish_install.sh script again and see if that updates the database but I don’t know if it will. KA-lite is also replaced by Kolibri which is included in the other image. Everything that is available in KA-Lite is available in Kolibri but content should be installed through Kolibri. I included instructions for that in the readme file. If the finish_install.sh doesn’t fix it I suggest trying out kolibri.


Jamesk, I was trying to get the Spanish image going on the Pi Zero W. However, get a 404 not found when look for your custom images.

I had downloaded the current version, but was fumbling around with novice issues.


Hi @Patrick_Coyle1,

Sorry about that. I am uploading a new KA-Lite image today and a new Kolibri one will follow soon after. There were some shutdown bugs in a version of Kolibri included in those other images as well as some issues with Wikipedia modules that are now fixed.


Hi again,

I have upload an image in a comment at the end of this post RACHEL-Pi Image for Raspbian Stretch . This is a KA-Lite version that you can try with the Pi Zero W.