Rachel-Plus 3.0 cannot boot up

Recently I Have been noticing that the battery for my Rachel-Plus 3.0 was not charging if Rachel was turned on, but would charge when it is turned off. Now it cannot boot up altogether. The blue power button is turned on but the WIFI light is off. Please can someone offer me some advice on how to trouble shoot or resolve this problem. Cannot connect through LAN also (LAN light off when connected to a router).

hello. Did you solve it ?

Hello - this is symbolic either of a hardware failure of the HDD or a earlier software issue with our integration of Kolibri from late 2018.

I assume you have a HDD and not an SSD inside. The HDD is more sensitive to dust, movement, or improper shutdown of the device (particularly if you just hold down the power button). This can corrupt an HDD (we don’t see these issues with the SSD). This is possibly the issue.

For a period of time in late 2018 however, there was also a software issue with the integration of Kolibri which was causing a similar problem. @mataiwq – I know you’ve had a few orders, can you provide the last 6 digits of the LAN MAC ID to us?

hi jeremy the MAC as requested is c46f25. The module was purchased in November but was shipped in December 2019



There is a simple boot-up method which may get your Rachel device running. Equally, it may help determine the underlying issue. Please try the following and let me know of the outcome:

Prerequisite: USB keyboard

  1. Plug the USB keyboard into the USB port closest to the network port.

  2. Power on the device.

  3. Wait a minimum of 5 minutes (past the time it takes for the device to normally boot).

  4. Select ctrl+d on the keyboard. The device will finish booting within seconds, if successful.

Hi Steve,
I tried what you suggested, still no WIFI only the blue power on light is ON



Another thing to try is disconnecting the battery. There are seven screws on the back cover. I would recommend finding just the right screwdriver for these little screws and a small flat screwdriver to remove the cover. The battery cable disconnects easily once the cover has been removed. If the battery is holding a charge, it is less likely it may cause a boot issue, but I have seen this on devices, such as laptops. If this step doesn’t help, please leave the cover off. There is one more thing that we can try with the cover off.

in what system does racher run… ubuntu 16?

Hi Steve, I have removed the battery and tried to turn it on by connecting the power cable - still same problem



OK. One more step before we determine the best way to resolve the issue. However, if you would prefer to send the device back for repair/replace, we can do that too. In either case, thank you for your related efforts.

There are four screws connecting the hard drive mounting-plate to the device. Please unscrew them and disconnect the gently disconnect the SATA connector from the hard drive. Once the drive has been disconnected, retry booting. If the device still doesn’t boot, we can reinstall the OS from a USB drive and run a script to update databases from the hard drive. If the device boots, we can resolve the apparent hard drive issue.

Hi Steve,

I would prefer to send the device back. Please would you post which address to send it too


OK. I will email the return label.