RACHEL USB port corrupts SSD

I run into a problem that two of my SSD drives are no longer visible on windows after plugging them into the RACHEL CMAL100 with the intention to download material to the local content. The first one is an ADATA protable SSD that I use as a backup and the second one is a 1TB SSD in a Sata USB-C external housing. Both SSD are not showing as a volume anymore when plugged into the Windows Laptop. I can find them on the partitioning table fully partitioned but not with showing any format.
Can anybody advise? Is this a bug in the linux system? Did CMAL 100 re-partition my SSD??

Are they possibly formatted to the EXT4 filesystem after connecting them? These won’t show on windows without a driver or program like Ext2Read.

true - great surprise - they have been reformatted to EXT4. I was able to read the drive with freeware Linux Reader von Diskinternals. To my disappointment, it really crashed all my data that I had stored on my NTSF formatted SSD without ever asking me any question. So use great caution when plugging a USB SSD drive into a RACHEL Plus capsule!

Hi Rod,

My sincerest apologies for the device reformatting your drives without notification… I will add this issue to be addressed on next release. I suspect the device was rebooted with SSD connected to the USB shows as /dev/sda (in place of the internal drive), which initiates the drive format (device thinking the block storage device is the internal HDD. I will investigate and resolve. Again, I apologize for any difficulty which this issue may have caused.

Thanks Steve
for your concern and action on this. It took two good days to recover everything. Now that I downloaded all the modules in zip format from your FTP to my SSD as a remedy for field action in the offline environment I have a question re installation on a CMAL100. Can I install the modules straight from the SSD without extracting or do I have to extract all of them first and just transfer the module folder to rachel/modules? I could not figure out why they are packaged in the VAR folder and suspect that is your normal upload script I could use via Admin/ Install/ Advanced?

Before the incident I had copied all the module folders from a current CMAL100 to an external SSD using WinSCP on my laptop.

If you have an update how to connect two CMAL100 in a slave mode to copy from a current CMAL100 to an older one that would help for field recovery.
In November I had some issues with both capsules that I purchased from WP Kenya (Bonface) as they would not load local content. Kolibri was already used by someone preventing us from setting it up for our school because we did not get admin rights. I would suggest that you deliver Kolibri with a superuser - admin / RACHEL+1 account to assure access.

For now all my RACHEL Plus servers are up to date and running as I will be in Zimbabwe delivering systems for 5 rural schools next week. I hope that we will not run into reformatting problems!

As wiLearn 4 Life is stepping up the use of mobile learning in remote locations – looking forward to a good collaboration!

Have a successful and happy 2019!

Hi Rod,

Let me help solve your objective directly. But first, I will answer some of your questions. As I understand it, the Learning Equality team worked with our team to leave the admin account uninitialized. In order for greater potential opportunity to gather user stats (used for contentious improvements), each kolibri deployment must be unique. So we moved from creating the admin account to leaving it uninitialized for each user, region… to do so. Net, potential contentious improvement value is dependent upon Rachel Plus admins creating the admin account before deployment. I will check to see if there was an announcement on this form and if not create one, stating the aforementioned (thank you).

Regarding module “var” folders: I will need to looking the why, as this setup predates me. I am sure there is a good reason within the overall usages of these files across a number of products & releases. For now, I can help work within that structure specifically for the Rachel Plus 3’s (CMAL100).

Ultimately, it sounds like you (a) you want your Rachel Plus devices up to the latest (OS/environment) rev, and (b) load, extract and install a set of zipped modules. A couple questions first to make sure that I have the correct baseline in which to more efficiently/accurately assist.

  1. Please confirm that your Rachel Plus devices are "RACHEL Installer 3.0.2 ", via “admin”->“Version” tab (admin login: admin / Rachel+1). I want to ensure that before we proceed.

  2. Please confirm, if you unzip a couple of the smaller modules, you see two folders. The first is the name of the module (example: en-local_content) and the second is the “var” directory?

  3. Do you have an existing Rachel Plus 3 with Installer 3.0.2 and all modules install and working as expected? If so, do you have access to a home wi-fi, router or switch, where you can connect two Rachel Plus units via Ethernet?

  4. Another option: if you have all of the modules that you wish to install loaded on a storage device, we can provide a relatively easy setup, where you can stream the modules from the Windows device while connected to the Rachel Plus as an access point. This may be a better option, as you would not need a 2nd Rachel Plus device to reload content.

Let’s get you set up so next week has all of the success which you envision. Option 4?

(a) & (b) are correct

  1. Installer 3.0.2 is present
  2. thats the unzip sequence E:\en-blockly-games.zip\var\modules\en-blockly-games - it contains the var folder and also the modules folder before the effective application folder
  3. Yes - access to router is here, but not always in the field, so Option 4 is preferred
  4. yes all zip files are now on my storage device. Some I have extracted to transfer via winSCP via cap (or root) to the modules folder.

I prefer updating RACHEL 3 modules via my windows laptop and wifi or ethernet

OK. I’ll have access to a Windows device this evening. Will develop a utility and procedure. The utility will unzip all modules in a directory, copy the content to the Rachel Plus and complete the install of each module. Note that some modules have a script that integrates content into databases and more. I will provide a like to a procedure, utility and lightweight app to download in the morning… The procedure should take you ~5-10 minutes, excluding the transfer and install time, which the utility will do once kicked off.

FYI. Still working… Still targeting today…

Clearly taken longer than expected… There were a number of implementation iterations necessary to provide the most reliable and safe means for local file upload. I am in QA phase, making sure data remains protected both on the content source device and existing content on a given Rachel Plus device.

For explicit replication purposes, what partition and format was your SSD USB? If windows, I would expect:

Partition = dos partition
Format = ExFAT, FAT32, FAT16, FAT or NTFS

Thanks Steve, I have used NTSF but now switched to ExFAT

I am about to tranfer the data collected on local content from one capsule to another - is that possible via WinSCP? We have large school repositories here in Zimbabwe and we like to promote the distribution of curriculum aligned OER that was collected by the teachers.

If WinSCP is like the Linux scp command (I suspect it is based off of it), is a non-interruptible command method. I.E., very slow and if interrupted, does not start where it left off. Considering transferring roughly 500GB, could take a day or more if all went perfectly. You can ssh into one device and copy from the other device, but both Rachel devices would need to be on the same Wi-Fi network during transfer. Or, you would need two Ethernet cables and any cheap Ethernet switch. See 6 steps below to perform a full module transfer.

Do you have a way to ssh from Win? If not I can provide a link to a small download.

  1. ssh root@IPaddressCAP1
  2. pswd: 123lkj
  3. rsync -Pav root@IPaddressCAP2:/.data/RACHEL/rachel/modules/ /.data/RACHEL/rachel/modules/

The rsync command is restart-able and this method would be much faster. Also, a small few of the modules you will need to run finish-install.sh within the main folder of such modules. While still in ssh, find the locations:

  1. cd /.data/RACHEL/rachel/modules
  2. ls -l */finish_install.sh | awk ‘{print $9}’

Example of output:

For each line that gets returned, copy/paste with a period and space in front. Example:
6) . zz-kolibri-upgrade/finish_install.sh

I expect to have the utility posted today if you would like to use that instead. It is a little more user friendly. Will announce when posted later. Also, I will be working to provide a Rachel native method to safely copy modules from USB. Plug and click… That feature is a few weeks off however.

Here is the procedure for uploading multiple modules:


I consider this a mature Beta version release, as I haven’t loaded more than a dozen modules and a few kolibri channels. It will require more Q&A for full blessing. But it appears to work so far, with no known issues.

many thanks for the multimod instruction. I have not been able to use it yet. Guess I would like to wait for the plug and click version mentioned. Will you make a fix to prevent USB devices being reformatted without a prompt? I am a bit worried to connect my devices to RACHEL USB after that reformatting.

Back from a teacher training, the most burning question we now have is the copy of LOCAL CONTENT. How can we copy the content from one capsule and integrate it with the local content of another capsule - say add it, not overwrite the content that is already present. We have established a library system in the RACHEL Plus local content area and would like that library to be used in other schools that have RACHEL Plus.

Hi Rod,

The multi-mod install safeguards against the possibility of USB data lost in two ways. First, the script is to be executed and the user is prompted to insert the USB, only after the reformat feature has been completely disabled. So not even a reboot would result in USB data loss. Only after the transfer completes and initializes modules, will the feature become enabled again. Second, the script only supports ExFAT, FAT, FAT16, FAT32 formats. Each of which, the CAP will not reformat on reboot (over 50 reboots tested).

For Local Content, You may try this (I haven’t tried yet, but reported to work): login to admin->hardware. Scroll down to “To modify advanced hardware settings (WiFi, DHCP, Firewall, etc.) please click here”, click on the “Click Here”. Go to “Backup/Upgrade” tab (mid-left). Click “Generate archive” to download a tar archive of the current configuration files. To restore configuration files, you can upload a previously generated backup archive here.

If that doesn’t work for transferring Local Content settings… from one CAP to another, things become a bit more technical. There are four areas to address: 1: en-local_content, 2: /media/preloaded, 3: /medial/uploaded, 4: associated db. I suspect #1 (standard en-local_module) files remain unmodified. As for 2&3, depending upon what content has been customized, you would need to transfer these two directories recursively (perhaps use rsync). #4 you would need to export the customized db and import it to the target cap.

A post was split to a new topic: How Do I Add Search to a Module?