Tried firmware upgrade and have some issues with KA

Hi all,

I was trying to update a older Rachel Plus device last week when we were back in Tanzania. I tried to use a USB key that I had created back in the US, and I am not sure it actually updated the firmware, however when I started testing the KA it didnt load any data. Now, we had noticed that the teachers were not using KA actively, so maybe the content had already stopped loading.

Fortunately, we had bought a new Rachel as well, so we left that and brought the older model home. The new one works great with KA.

Btw… none of the devices would update or add content, they could both see missing updates and new content, but couldn’t download a single byte… I assume this is related to the wireless provider.

What do you suggest to get the older Rachel back to working condition as I now have fast internet?

Thanks in advance,


Hi Allan,

Please login to the old Rachel device as the admin and send a screenshot of the “Hardware” and “Version” tabs (whatever fits on your screen from the top of each page is fine). Also, please send a link to the upgrade which you performed? Thank you

Here is the info requested. I didnt remember the link that was provided by the website, but I took a screenshot of the content of the USB. Let me know if you cannot see the screenshots. Btw… the download of content now works here in the US.



Ping… Any suggestions regarding the upgrade or KA lite issue?