Vedoque and Local Module List

A couple of questions. Is there a non-Flash version of Vedoque available in Spanish?
ALso, after loading modules onto my RACHEL-Pis using WinSCP, (using the rachelpi_64EN/rachelpi_2020/rachel-pi-10_16_2020 image), in the Delete Modules section of the Install page I get the message “getLocalModuleList: Internal Error”. Is there any way to fix that?

Hi @ronsat

Vedoque has not been updated yet. It takes some time to develop modules and everything around that process. Since the January discontinuation of flash, we started with updating GCF to a 2021 version.

It’s strange to see that message in the delete modules area. I suspect this may be a permissions issue. After you transferred the modules with WinSCP, did you run the following command?

sudo chown -R www-data:www-data /var/www/modules

This will set the correct ownership on the newly transferred modules. Also, are you uploading RACHEL modules or custom modules?

Thanks James, I tried running the chown command again - but no luck. Some of the modules are loaded through the Install feature, and others were transferred from the zipped-modules directory on the site, then unzipped, and the var directory removed.

Oops - forgot to mention, the perms on some of the modules are rwxr-xr-x while on others it is rwxrwxr-x. Not sure if that makes a difference.

Hi @ronsat,

What I suspect is happening is the modules database and modules found on the filesystem are not matching. Changing the order of the modules and saving will sync them again, Try the following.

  1. Go to the modules page on the admin area
  2. Change the modules order so that the “Save Changes” button at the bottom is active
  3. Click save

Now try refreshing the other page and see if the error is still there.

If this doesn’t fix the issue, there may be some information in the error log that will give us an idea of what’s happening. Try running “sudo nano /var/log/apache2/error.log” and then press the page down key to scroll through and see if you can find any recent errors. If you can copy and paste or screenshot the output for me it may help us figure out what’s going on. Permissions shouldn’t affect this issue.


Thanks James
Tried following the process, but didn’t get anywhere. There were, however, three modules that weren’t loaded properly since they didn’t have rachel-index.php files - due to incomplete transfer from downloaded zipped modules. I removed es-cnbguatemala - as WinSCP transfers would always fail - I suspect due to file name length, and completed the transfers of the other two modules. I then rebooted the Pi, and redid the instructions that you gave in your note, and still had the getLocalModuleList: Internal Error message. Here is the content of the Error.log.

[Sun Apr 18 06:41:09.394440 2021] [mpm_prefork:notice] [pid 570] AH00163: Apache/2.4.38 (Raspbian) configured – resuming normal operations
[Sun Apr 18 06:41:09.394572 2021] [core:notice] [pid 570] AH00094: Command line: ‘/usr/sbin/apache2’
[Sun Apr 18 07:28:37.818811 2021] [mpm_prefork:notice] [pid 570] AH00169: caught SIGTERM, shutting down
[Sun Apr 18 07:29:00.169562 2021] [mpm_prefork:notice] [pid 576] AH00163: Apache/2.4.38 (Raspbian) configured – resuming normal operations
[Sun Apr 18 07:29:00.170805 2021] [core:notice] [pid 576] AH00094: Command line: ‘/usr/sbin/apache2’

Hi @ronsat,

The error log looks normal with just the startup/shutdown messages.

Since there doesn’t seem to be an error happening from the code itself, I think this might be an issue with the database. You can try to regenerate it with the following steps.

  1. Connect with WinSCP and browse to /var/www/modules
  2. Delete the modules that were not working
  3. Browse to /var/www/admin
  4. Right click the file “admin.sqlite” and rename it to “admin.sqlite.bak”.
  5. With your web browser, to the main RACHEL home page and refresh it.

This should trigger the database to be recreated with default settings and the modules you have installed. If it works, you can delete the admin.sqlite.bak file.

Hope that works

Hi @ronsat - I came across this the other day and the issue is with a rachel-index.php file thati s not UTF-8 encoded. If you see any modules on the main RACHEL page that have strange characters like a copyright symbol in the text, you can either re-encode that rachel-index.php to UTF-8 using software like notepad++ or delete that module and it should be fixed.

Thanks @jamesk . I will try this out.

1 Like