Wireless SSID does not appear

Hi, We just received our RACHEL-Plus device and after powering it up we do not see the SSID showing up… We have tried from multiple devices (iMac, Macbook, iPad) - but no luck… the blue wireless lights are on.

What are we doing wrong?

Have you let it run for 10 minutes or so? I would login via a LAN network and go to the admin panel to change the SSID or WiFi channel.

Yes, I have left it on for a hour or so, also tried to press the reset (hole next to on-button). I have plugged it into my router and still can’t connect to the IP address… I also tried connecting my macbook into the same router, switched off wireless and it could easily see my other systems, but no RACHEL. I tried switching the network cables… still nothing.

The power is on, the blue (wireless) light comes on, blinks a few times and then stays solid.

Did we get a dud? My wife leaves next Monday, so we need this fixed or a new one sent…I am perfectly happy paying for another to get it sent as soon as possible while we troubleshoot this.

Hi Ina - does the blue light stay solid for the whole time period? It is supposed to ‘breathe’ - slowly flashing on and off if it is working correctly.

We actually don’t have any in stock at the moment, otherwise I would be happy to send you a replacement. @Jfield do you have any over there?

@Ina – please try this if your device is truly stuck on all blue lights

Ok, did the restore via a USB stick, and it seemed to work fine… i.e. solid little blue dot and then flashing blue lines. After about 10 minutes there was non flashing blue lines.

Turned off, unplugged USB, plugged in network to my router and restarted the device… now what?

Still have blue non-flashing lines and can’t see the SSID, I also can’t see the device on my network.


So you have no way of communicating with the device at all right?

There isn’t anything else I can do about it, I’m sorry. I’ve never seen the recovery USB not work. If you send us an e-mail or your order number I can send you a return label, but we don’t have any replacements right now. New devices are currently in the port of long beach. What about a RACHEL-PI?

Correct, we can’t communicate with the device at all. I tried doing the Recovery again, no luck.

We’re going to need RACHEL-Plus for the number of students in a class, battery backup, as well as its expanded content to support the classes at the school. As a purpose for my trip to Tanzania next week was to deploy RACHEL-Plus, train teachers and have students use it in classroom, would appreciate if anything can be done to get RACHEL-Plus to us by this Saturday. So if your order can clear customs or somebody else has a working RACHEL-Plus and you can get it to us by Feb 18th, that would be great.

In meantime, we can order RACHEL-PI with the English content (we already deployed at the school Wiki for Schools, and KA Lite Essential and had hoped for full versions on the PLUS and other content, but assume if we can get RACHEL-PI by Friday, we can add content from RACHEL Friends and delete content unlikely be used in the primary school to make space. Let us know if need to place order online and if someone could first test its function before sending to arrive by Friday.

The order # for the RACHEL-Plus received is 1477.

Great, I can’t believe it turned out so poorly. I do have one RACHEL-Plus here that has a small cosmetic mark on the front, it’s just a 2 inch black squiggle. I use it for demonstrations, but if you’re OK with the cosmetic defect I could send you that one?

I don’t think we will get the new devices cleared and ready by 2/18, let alone shipped and delivered.

@jeremy - I don’t have any new boxed ones, but I do have one clean unboxed one. It would take a couple hours to load it up (I started the build, just in case)- let me know if you want me to send it.

@Ina - Sorry to hear you ran into trouble! Just so you know, we do manually test every unit before we send them out. Something must have gone wrong during shipping :confused:

We will take what ever you can send - thanks @jfield and @jeremy, appreciate your efforts!

When you say you are leaving next Monday, do you mean the 20th? If I send it to the address on the original order to arrive before Friday the 17th, will that work?

Yes, we are leaving on the 20th, so arriving on the 17th works for us.

We’re thinking of ordering a RACHEL-Pi in addition, to give us a back up if any problems arise with the Plus. If we place order online now, do you have a Pi that you add with the shipment of the Plus and how should I specify the shipping cost when placing the order for the Pi.

Yes, I can combine those. Just go ahead and order a Pi with standard shipping and I’ll make sure they both get to you in time.

Just placed order (#1484) for the Pi with English content. Thanks @jfield!

Also appreciate testing Pi and Plus before shipping.

1 Like


We received the Rachel-Plus and it started “breathing” right away, so we are now connected, and can see the content. Thanks so much for sending it so we could get it in time.

However, I can’t seem to update or add the content. I have plugged the Rachel into my router, it has an IP address on my network. I tested that I can connect to that IP address and get the home page and also log into the admin interface… however, the content just sits in waiting.


It is now working with the downloads.

my inglesh is no good.
i see your problem, is the same than me. well the problen is the next. i try to updatede to cap2 in a moment all is good, but than turn off the server and the turn on server the wifi blue solid and no wifi, no lan.

The solution is make usb but with Download “old HD schema” RACHEL USB Recovery Image.

1 Like