Unresponsive CAP 1

I finally got one of the two CAP1 units back from the field (Tanzania) in order to update the firmware for the battery and further diagnose the problem I reported Loss of RACHEL SSID after power down power up where there was no fix.

I am unable even to talk to the box. Sometimes my router registers the new DHCP IP address for the unit, but there is no response to ping. Other times my router doesn’t even see the box and so there is no address to ping.

Though I still see the heartbeat in the lights, this is the box that doesn’t send out an SSID as reported in the link above, and no fix came back to me regarding that problem.

How do I talk to a Rachel Box that doesn’t even respond to a ping? I also tried SSH but that failed so I thought I would try first for a ping.

Thank you for your guidance!

. . . . . . Ken

Hi Ken,

Can you try doing a full reset with the USB device? You’d follow the same instructions as here:


Forgive me, Jeremy, I neglected to say the reason I wanted to talk to the box is that the unit is not reading the USB to do a full reset. I wanted to get a command line so I could query the mounted drives. My first action upon receiving the box was to try to reset it.

I wrote the image onto the USB yesterday and I verified in two computers that the image is on the stick.

When I start up the CAP1 with the USB in place, the light blinks 25 times in about 15 seconds, goes solid for about a minute, then the heartbeat starts. Your instructions “wait at least 8 minutes until the lights on top are lit solid” just don’t happen. The heartbeat just goes on continuously.

I know this isn’t going to seem logical when I tell you this. All I can say is that for years, I would have devices that did not recognize USBs right out of the box. I had about 40 ADATA USB 3.0 sticks, and there were some devices which just would not recognize that a USB was inserted in the back. I could use one USB stick on a RACHEL unit, it would work, and then take that same stick to a different unit and get no recognition of the USB.

After years of this driving me crazy, I bought 12 SanDisk USB 3.0 drives and I have literally never had the problem again. I was mostly annoyed I hadn’t done this earlier than excited it fixed the problem. What you’re telling me is exactly the behavior I had with my old ADATA drives sporadically.

If you want to ship it back to us, I can try doing it here.

Okay … I found another USB 3.0 stick and after a number of tries I still do not have 1.2.1 loaded but I do have changed behaviours.

The original RACHEL SSID is now there, replacing the custom SSID I had before I started this process.

Also, my SSH now prompt reads:


… where I’m quite certain that before it was WRTD-303N-Server, though I cannot be certain.

The box is still not responding to a ping, but I’m in with SSH (and my previously-set password, not the default password).

I’m going to the shops tomorrow to find a SanDisk brand USB 3.0 since this LexMark isn’t working. I’m confounded why the brand is so important.

Shipping the box back is too expensive. This is a volunteer effort.

Thanks, @gkholman for the update.

WAPD-237N-Server is the model number of a custom firmware produced by the manufacturer for a one-off project in Kenya (not for me).

That’s incredibly strange.

Are you sure that download of 1.2.1 came from our website?

It doesn’t seem like it took the 1.2.1 which should wipe all the unit and replace with default info. I wonder if this unit somehow got the newer device firmware and is ignoring the USB on purpose because it sees the firmware as older.

Let me know how a new USB goes and if you can confirm this device never got a CAP 2.0 firmware.

Yes, I downloaded 1.2.1 from your web site.

The USB stick active light does flicker during startup, every time.

Yes,the box at one point had 2.0 firmware because your update procedures did not specify CAP2 at the time, This discussion Create and Use and USB Recovery revealed late to Sam and Joshua that I was working with a CAP1 box. The first edition of your update procedures did not limit the activities to only post-2015 boxes and so I was working with a 2015 box following those instructions.

I believe at one point one of your colleagues SSH’ed into my box through DDNS and tweaked things to work for me.

This is taking me hours. The box is supposed to go back to Tanzania on December 31, which is why I’m scrambling during the vacation period to finish the upgrade.

Chiming in with some clarifications - @jeremy, I’m pretty sure the latest 1.2.1 USB (which uses the 1.2.24 firmware from Gemtek) changes the prompt to “WAPD-237N-Server” – that’s just how Gemtek sent it over, so that is expected (if somewhat confusing) behavior. So that would indicate a successful recovery.

A note on the USB – it’s not the brand per se, but that the drive is of high quality. We’ve used dozens of manufacturers and the success/failure rates are vastly different. I have, like Jeremy, had lots of USBs that were non-bootable (though seemed to work otherwise) out of the box or after a few uses. It’s astonishing how low quality some of them are. SanDisk is just one that we happen to know is reliable. I’m sure there are others. In any case, it sounds to me like the one you used most recently worked.

So the question at this point: is the ping the only thing that’s not working? Any chance you’re no a network that filters out ping requests?

Are you able to connect to the box through your browser? Is the content there? I really want to help you get this working!

Thank you, very kindly, for the enthusiasm to get this working.

Following the instructions regarding upgrading the box at Update Firmware on RACHEL-Plus 1.0 (WRTD-303N Model), the Version tab of the administration page still reads 1.2.0 for the Rachel installer and not 1.2.1. So I’m assuming it hasn’t been updated.

Sorry, Jonathan, you also asked about other services and network filtering. I am able to ping other devices (NAS, printer, etc.) on the network. And I just successfully addressed the port directly from a web browser and got the RACHEL home page (I hadn’t thought to try that before). DDNS appears to be working fine. I’ll PM you the DDNS address.

Ok, thanks for the info. Yeah, it sounds like an update failure of some sort. Based on the reset SSID and the new hostname, I’d say the firmware portion took but then the rest of the software update didn’t go through.

Can you send me a screenshot of your versions page? And also, if possible check the firmware page at port 8080 for the version there (it should be 1.2.24).

If you can get me a public IP address, I will log in and take a look…

I’ve just added port 8080 to be forwarded through DDNS to port 8080. Port 8081 goes to 80 and 8082 goes to 22.

So I took a look at the device – it appears the RACHEL content was working except for ka-lite, which I’ve fixed. That indicates that the update process didn’t totally complete, but it sure looks like everything else got successfully updated (you have the latest contentshell, for example).

I verified that the firmware is the latest version (1.2.24) and the battery patch was applied.

I wasn’t able to ping the unit from here either, but network in general seems to be working both in and out of the device.

Are you still having trouble with the WiFi? What issues are you experiencing now?

Thanks so much, Jonathan!

The WiFi problem reported earlier is not repeating at this time. It seems stable with the default parameters. I will now configure the box for Tanzania and ship it back.

Just to be clear, the CAP admin firmware version 1.2.24 represents the battery patch (I don’t have to look elsewhere), and the fact that the RACHEL module admin reads 1.2.0 for “Rachel Installer”, and not 1.2.1 as indicated elsewhere on this site, is not relevant.

BTW, does it matter which model of SanDisk USB 3.0 stick to purchase? My local shop has the “SanDisk Ultra Flair 32GB USB 3.0 Flash Drive” in stock. I will purchase one today for when the other box comes back to Canada for refurbishing (I’m borrowing the Lexar disk from my son).

Thank you, again, this is a relief! I will finish my testing and post here if anything surprising shows up.

All testing yesterday went well. The RACHEL unit was plugged in for about 6 days while I was doing my work on it. I shut it down by pressing the button on the front and it went through its proper power down process. I boxed up the unit for travel.

This morning I thought I would try another test (regarding PDF MIME types) that came to mind, so I pulled the unit out of the box and powered it up on battery. Within 20 seconds the unit shut down. The unit then did not respond to the button until after the unit was plugged in again, then it powered up.

Is there a diagnostic available on the battery condition? I’ve looked at the CAP admin page and the battery status states 100%. So I powered down.

I unplugged the unit and powered back up again. Again, after 20 seconds the unit shut down. It happened just after the heartbeat started.

I plugged the unit back in and the startup worked just fine.

Then after it was up and running, I unplugged the unit. It lasted only about 10 seconds or less before shutting down.

Since the national power in Tanzania is not at all reliable, this is an issue. Unfortunately, based on yesterday’s tests, I’m now scheduled to be handing off the unit this afternoon to the educator who is taking the unit back.

I’ve put the unit back on the DDNS, plugged in and turned on.

Yes: 1.2.24 is the battery patch firmware. Additionally I checked /root/battery_log to verify that the patch successfully completed. I’m not sure why the installer version number didn’t get bumped, but I checked and you have the latest contentshell and kalite installed, which are the main components. If you encounter any other problems let me know but it seems like you should be set.

For the USB, I think it’s really just making sure you get something high quality – there’s lots of off-brand junk out there. Jeremy has had good luck with SanDisk brand – I would imagine most of their models would be solid. I’ve had good luck with Kanguru (which I love because they include a write-protect switch) but they’re relatively expensive.

Best of luck!

By “other problems” do you mean “other than the automatic shutdown after 20 seconds problem” that I just reported? This unit offers no battery backup in any way. When I unplug the unit, it shuts down in 10 seconds. When I start the unit unplugged it lasts less than 20 seconds. I detailed the steps in my previous note. So the battery patch is in, but does this mean now there is no battery operation? Thanks for helping me to understand this.

Sorry - I was responding to your previous message (which I got in email) where it sounded like all was well… I didn’t see the newer power problem until just now.

There are two possibilities here: a bad battery (it is older, but if it’s reading 100% it doesn’t sound bad) or a problem with the battery monitoring software. I can see your device right now, but it seems the password has been changed - if you put the default password back I will check it out.

As a note - this issue is unrelated to the firmware - it’s just a script that triggers a safe shutdown if the power level drops too low, but in some situations it has triggered a shutdown even when the battery was still OK. If that’s the problem it’s an easy fix. If it’s truly a bad battery that’s another story.

Let me know when the password is in place so I can check it out!

Ouch! Password changed. Sorry!

Ok, I just checked it out and unfortunately it’s not the battery monitor (the battery monitor is supposed to be disabled in 1.2.1 but I wanted to double check your setup) But the battery monitor was properly disabled, so the problem is most likely a real problem with the battery :frowning:

Not sure how to address that – @jeremy?